Bug 1255966 - rhc snapshot save timeout flag doesn't work
rhc snapshot save timeout flag doesn't work
Status: CLOSED DUPLICATE of bug 1080400
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Timothy Williams
Yan Du
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-22 09:09 EDT by Dmitry Miroshnichenko
Modified: 2016-03-18 14:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-18 14:25:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Miroshnichenko 2015-08-22 09:09:24 EDT
Description of problem:
rhc snapshot save tool exceeds timeout even if --timeout flag is specified

Version-Release number of selected component (if applicable):
Making snapshot for this jenkins application. Other details could be provided
https://openshift.redhat.com/app/console/application/5458ba5f4382ec26f300031f-jenkins

How reproducible:
Make a snapshot of jenkins app https://openshift.redhat.com/app/console/application/5458ba5f4382ec26f300031f-jenkins with rhc tool 

Steps to Reproduce:
1.Execute the following script:
echo 'Started'
date
rhc snapshot-save opendingo/jenkins --timeout 20800
echo 'Ended'
date
2. Notice in actual results difference in 1 hour(default timeout)

Actual results:
Started
Sat Aug 22 14:40:07 MSK 2015
Pulling down a snapshot of application 'jenkins' to jenkins.tar.gz ... 
Error in trying to save snapshot. You can try to save manually by running:
ssh 5458ba5f4382ec26f300031f@jenkins-opendingo.rhcloud.com 'snapshot' > jenkins.tar.gz
Ended
Sat Aug 22 15:40:15 MSK 2015

Expected results:
green letters: done

Additional info:
Can provide any additional info. Also the alternative command recommended by rhc tool isn't working
Comment 1 Timothy Williams 2015-09-04 13:57:39 EDT
Dmitry,

Thanks for the report. Is this on a Windows or Max/Linux/Unix system? Additionally, how much additional storage does your application use? Could you provide the output of `quota -s` while ssh'd into the application?

If on a linux/unix/Mac system, rhc simply calls the ssh command given in the error output of the command. The timeout could be in the ssh implementation on your client system, or perhaps in the openshift.com server. 

If on a Windows system, we use the 'net/ssh' rubygem. We don't specifically specify any timeout, so it is likely a timeout on the openshift server if this is happening on a windows system.
Comment 2 Dmitry Miroshnichenko 2015-09-08 05:40:51 EDT
(In reply to Timothy Williams from comment #1)
> Dmitry,
> 
> Thanks for the report. Is this on a Windows or Max/Linux/Unix system?
> Additionally, how much additional storage does your application use? Could
> you provide the output of `quota -s` while ssh'd into the application?
> 
> If on a linux/unix/Mac system, rhc simply calls the ssh command given in the
> error output of the command. The timeout could be in the ssh implementation
> on your client system, or perhaps in the openshift.com server. 
> 
> If on a Windows system, we use the 'net/ssh' rubygem. We don't specifically
> specify any timeout, so it is likely a timeout on the openshift server if
> this is happening on a windows system.

I tried to make snapshot on both Linux and Windows systems. 

In case of Windows I've got an error:
Pulling down a snapshot of application 'dustri' to dustri.tar.gz ... Could not parse PKey: no start line
You can look at this bug here https://bugzilla.redhat.com/show_bug.cgi?id=1197301
Also I tried other "recipes" with net-ssh. Nothing helps.

Regarding linux system there is 11G disk space for cartridge on Openshift Online server. And I wonder how you don't know where is a timeout on client or server! Please check this bug.
Comment 3 Timothy Williams 2015-10-23 10:42:38 EDT
Should be resolved with https://github.com/openshift/rhc/pull/711
Comment 4 openshift-github-bot 2015-10-26 15:32:51 EDT
Commit pushed to master at https://github.com/openshift/rhc

https://github.com/openshift/rhc/commit/1193dc3a91dcbe2fc9f2c432b3f5c6d54ae84666
Honor global timeout during snapshot save

Bug 1255966
https://bugzilla.redhat.com/show_bug.cgi?id=1255966

When saving a snapshot, honor the timeout passed as a global argument, or defined in configuration.
Comment 5 Timothy Williams 2016-03-18 14:25:37 EDT
Closing this bug - the pull request should help but likely doesn't resolve the whole issue. The problem and proposed solution are documented in another bug, which this has been marked a duplicate of.

*** This bug has been marked as a duplicate of bug 1080400 ***

Note You need to log in before you can comment on or make changes to this bug.