Bug 1256040 - Can't break bond via RESTAPI, unexpected exception
Can't break bond via RESTAPI, unexpected exception
Status: CLOSED DUPLICATE of bug 1229632
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
high Severity high
: ---
: 3.6.0
Assigned To: Marcin Mirecki
GenadiC
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 11:05 EDT by GenadiC
Modified: 2016-02-10 14:50 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 06:10:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine, supervdsm and vdsm logs (993.71 KB, application/zip)
2015-08-23 11:05 EDT, GenadiC
no flags Details

  None (edit)
Description GenadiC 2015-08-23 11:05:03 EDT
Created attachment 1066040 [details]
engine, supervdsm and vdsm logs

Description of problem:
It isn't possible to remove a host network interface using the RESTAPI. Add a host with two network interfaces and create a bond using the GUI, then try to delete the bond using the following script:

---8<---
#!/bin/sh -ex

url="https://engine.example.com/ovirt-engine/api"
user="admin@internal"
password="..."
host_id="..."
nic_id="..."

curl \
--verbose \
--insecure \
--user "${user}:${password}" \
--request DELETE \
"${url}/hosts/${host_id}/nics/${nic_id}"
--->8---

It will fail and return the following error message:Bond attached to vlan, remove bonds vlan first

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run script above with appropriate host and bond IDs
2.
3.

Actual results:
Test fail with the following error message:Bond attached to vlan, remove bonds vlan first, though thre is no VLAN attached

Expected results:
operation should succeed

Additional info:
Comment 1 Barak 2015-09-09 06:10:03 EDT

*** This bug has been marked as a duplicate of bug 1229632 ***

Note You need to log in before you can comment on or make changes to this bug.