Bug 1256048 - Commit a previewed snapshot with Cinder disk should remove all its "children" snapshots
Commit a previewed snapshot with Cinder disk should remove all its "children"...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Maor
Natalie Gavrielov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 12:28 EDT by Maor
Modified: 2016-03-10 10:16 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 08:32:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
ylavi: planning_ack+
tnisan: devel_ack+
ylavi: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 43814 master ABANDONED core: Add stored procedure for descendant snapshot Never
oVirt gerrit 43815 master ABANDONED core: [WIP] Remove descendant snapshots when committing a previewd snapshot. Never
oVirt gerrit 48937 master MERGED core: Add Cinder helper method for candidate volumes to delete. Never
oVirt gerrit 48938 master MERGED core: Add updateSnapshot to CinderDiskParameters. Never
oVirt gerrit 48939 master MERGED core: Use linked list instead of list. Never
oVirt gerrit 48940 master MERGED core: Add a new Cinder volume parent command. Never
oVirt gerrit 48941 master MERGED core: Restore snapshot should handle Cinder snapshot. Never
oVirt gerrit 48942 master MERGED core: Refactor, Use RemoveCinderVolumeParentCommand method. Never
oVirt gerrit 48943 master ABANDONED core: Refactor, use getDisk at RemoveCinderDiskCommand. Never
oVirt gerrit 49413 master MERGED core: Get initial Cinder volume to restore from. Never
oVirt gerrit 49414 master MERGED core: Get previewed snapshot's images by the snapshot's OVF. Never
oVirt gerrit 49416 master ABANDONED core: Remove redundant Cinder snapshots after commit. Never
oVirt gerrit 49417 master MERGED core: Rename parameter cinderDisks to cinderDisksToRestore. Never
oVirt gerrit 49418 master MERGED core: before unlock a VM, fetch it from the DB Never
oVirt gerrit 49419 master MERGED core: RestoreCinderSnapshot should delete volumes by order. Never
oVirt gerrit 49420 master MERGED core: Re-factor restore snapshot for Cinder disks. Never
oVirt gerrit 49428 master MERGED core: Add cinder volume type for VM's disks' OVF. Never
oVirt gerrit 49685 master MERGED core: cleanup, use getDiskImageDao at isCinderHasNoImages. Never
oVirt gerrit 50054 ovirt-engine-3.6 MERGED core: Add Cinder helper method for candidate volumes to delete. Never
oVirt gerrit 50055 ovirt-engine-3.6 MERGED core: cleanup, use getDiskImageDao at isCinderHasNoImages. Never
oVirt gerrit 50056 ovirt-engine-3.6 MERGED core: Add updateSnapshot to CinderDiskParameters. Never
oVirt gerrit 50057 ovirt-engine-3.6 MERGED core: Use linked list instead of list. Never
oVirt gerrit 50058 ovirt-engine-3.6 MERGED core: Add a new Cinder volume parent command. Never
oVirt gerrit 50059 ovirt-engine-3.6 MERGED core: Restore snapshot should handle Cinder snapshot. Never
oVirt gerrit 50060 ovirt-engine-3.6 MERGED core: Refactor, Use RemoveCinderVolumeParentCommand method. Never
oVirt gerrit 50061 ovirt-engine-3.6 MERGED core: Get initial Cinder volume to restore from. Never
oVirt gerrit 50062 ovirt-engine-3.6 MERGED core: Add cinder volume type for VM's disks' OVF. Never
oVirt gerrit 50063 ovirt-engine-3.6 MERGED core: Get previewed snapshot's images by the snapshot's OVF. Never
oVirt gerrit 50065 ovirt-engine-3.6 MERGED core: Rename parameter cinderDisks to cinderDisksToRestore. Never
oVirt gerrit 50066 ovirt-engine-3.6 MERGED core: before unlock a VM, fetch it from the DB Never
oVirt gerrit 50067 ovirt-engine-3.6 MERGED core: RestoreCinderSnapshot should delete volumes by order. Never
oVirt gerrit 50068 ovirt-engine-3.6 MERGED core: Re-factor restore snapshot for Cinder disks. Never

  None (edit)
Description Maor 2015-08-23 12:28:35 EDT
Description of problem:
Commit a previewed snapshot with Cinder disk which has "children" snapshots does not remove all the "children" snapshots after the snapshot gets committed

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a VM with Cinder disk
2. Create a snapshot (Lets call it snapshot A)
3. Create another snapshot (Lets call it snapshot B)
4. Create another snapshot (Lets call it snapshot C)
5. preview snapshot A
6. Commit the previewed snapshot

Actual results:
Snapshot gets committed but the snapshot B and C are still existing

Expected results:
When snapshot A gets committed, snapshot B and C should get deleted.

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:54:04 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Yaniv Lavi 2015-10-29 08:30:42 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Sandro Bonazzola 2015-12-23 08:44:21 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA

Note You need to log in before you can comment on or make changes to this bug.