Bug 1256123 - rhcert-backend can not test internal audio device.
rhcert-backend can not test internal audio device.
Status: CLOSED DUPLICATE of bug 1248707
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-hardware (Show other bugs)
1.0
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: brose
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 22:40 EDT by garrickyang
Modified: 2015-08-24 11:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 11:23:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description garrickyang 2015-08-23 22:40:39 EDT
rhcert-backend can not test internal audio. 
There are two audio device on the laptop, internal audio and DP/HDMI audio. when run the audio test with command "rhcert-backend run --test=audio", the test suite run on DP/HDMI audio twice and get "PASS", but not run on the internal at all. 
If remove the DP/HDMI monitor and test again, it will test on card0(DP/HDMI audio) twice with command "aplay /usr/share/sounds/alsa/Front_Right.wav -D plughw:0" and get "FAIL".

audio device in the test plan:
audio      udi=/devices/pci0000:00/0000:00:03.0/sound/card0 
audio      udi=/devices/pci0000:00/0000:00:1b.0/sound/card1 

run time log:
...
Running audio on udi=/devices/pci0000:00/0000:00:03.0/sound/card0 testserver=rhcert71 

Sound Card:

udev device: /devices/pci0000:00/0000:00:03.0/sound/card0
------------------------------------------------------
ID_VENDOR_ID 0x8086
SUBSYSTEM sound
ID_VENDOR_FROM_DATABASE Intel Corporation
DEVPATH /devices/pci0000:00/0000:00:03.0/sound/card0
ID_PATH_TAG pci-0000_00_03_0
ID_MODEL_FROM_DATABASE Broadwell-U Audio Controller
ID_PCI_SUBCLASS_FROM_DATABASE Audio device
TAGS :seat:systemd:
SYSTEMD_WANTS sound.target
ID_PATH pci-0000:00:03.0
ID_FOR_SEAT sound-pci-0000_00_03_0
SOUND_INITIALIZED 1
ID_PCI_CLASS_FROM_DATABASE Multimedia controller
info.udi /devices/pci0000:00/0000:00:03.0/sound/card0
USEC_INITIALIZED 21418
ID_MODEL_ID 0x160c
PULSE_PROFILE_SET extra-hdmi.conf
SOUND_FORM_FACTOR internal
ID_BUS pci


/proc/asound/card0/pcm8p/info
card: 0
device: 8
subdevice: 0
stream: PLAYBACK
id: HDMI 2
name: HDMI 2
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1

/proc/asound/card0/pcm7p/info
card: 0
device: 7
subdevice: 0
stream: PLAYBACK
id: HDMI 1
name: HDMI 1
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1

/proc/asound/card0/pcm3p/info
card: 0
device: 3
subdevice: 0
stream: PLAYBACK
id: HDMI 0
name: HDMI 0
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1

This test plays a sound sample and records it to another file.
                    Please use the Volume Control application and insure that the 
                    Capture settings will record the sound. Continue? (yes|no) y
response: y
response: True
Note: No Capture Support
aplay /usr/share/sounds/alsa/Front_Right.wav -D plughw:0,3
Playing WAVE '/usr/share/sounds/alsa/Front_Right.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
aplay /usr/share/sounds/alsa/Front_Left.wav -D plughw:0,3
Playing WAVE '/usr/share/sounds/alsa/Front_Left.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Did you hear the played sound? (yes|no) y
response: y
response: True
copying attachments...
checking directory /var/log/rhcert/runs/1/hwcert/audio 
Skipping output.log
saveOutput: /var/log/rhcert/runs/1/hwcert/audio/output.log
Return value was True
Running audio on udi=/devices/pci0000:00/0000:00:1b.0/sound/card1 testserver=rhcert71 

Sound Card:

udev device: /devices/pci0000:00/0000:00:03.0/sound/card0
------------------------------------------------------
ID_VENDOR_ID 0x8086
SUBSYSTEM sound
ID_VENDOR_FROM_DATABASE Intel Corporation
DEVPATH /devices/pci0000:00/0000:00:03.0/sound/card0
ID_PATH_TAG pci-0000_00_03_0
ID_MODEL_FROM_DATABASE Broadwell-U Audio Controller
ID_PCI_SUBCLASS_FROM_DATABASE Audio device
TAGS :seat:systemd:
SYSTEMD_WANTS sound.target
ID_PATH pci-0000:00:03.0
ID_FOR_SEAT sound-pci-0000_00_03_0
SOUND_INITIALIZED 1
ID_PCI_CLASS_FROM_DATABASE Multimedia controller
info.udi /devices/pci0000:00/0000:00:03.0/sound/card0
USEC_INITIALIZED 21418
ID_MODEL_ID 0x160c
PULSE_PROFILE_SET extra-hdmi.conf
SOUND_FORM_FACTOR internal
ID_BUS pci


/proc/asound/card0/pcm8p/info
card: 0
device: 8
subdevice: 0
stream: PLAYBACK
id: HDMI 2
name: HDMI 2
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1

/proc/asound/card0/pcm7p/info
card: 0
device: 7
subdevice: 0
stream: PLAYBACK
id: HDMI 1
name: HDMI 1
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1

/proc/asound/card0/pcm3p/info
card: 0
device: 3
subdevice: 0
stream: PLAYBACK
id: HDMI 0
name: HDMI 0
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1

This test plays a sound sample and records it to another file.
                    Please use the Volume Control application and insure that the 
                    Capture settings will record the sound. Continue? (yes|no) y
response: y
response: True
Note: No Capture Support
aplay /usr/share/sounds/alsa/Front_Right.wav -D plughw:0,3
Playing WAVE '/usr/share/sounds/alsa/Front_Right.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
aplay /usr/share/sounds/alsa/Front_Left.wav -D plughw:0,3
Playing WAVE '/usr/share/sounds/alsa/Front_Left.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Did you hear the played sound? (yes|no) y
response: y
response: True
copying attachments...
checking directory /var/log/rhcert/runs/1/hwcert/audio 
Skipping output.log
saveOutput: /var/log/rhcert/runs/1/hwcert/audio/output.log
Return value was True
...

test suite packages:
redhat-certification-1.0-20150707.el7.noarch
redhat-certification-information-1.7.1-20150618.el7.noarch
redhat-certification-hardware-1.7.1-20150618.el7.noarch
Comment 1 brose 2015-08-24 11:23:41 EDT

*** This bug has been marked as a duplicate of bug 1248707 ***

Note You need to log in before you can comment on or make changes to this bug.