Bug 125619 - Ant does not build servletapi correctly
Ant does not build servletapi correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vadim Nasardinov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 10:10 EDT by Gary Benson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 15:45:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Script to exercise the failure (928 bytes, text/plain)
2004-06-28 11:18 EDT, Gary Benson
no flags Details

  None (edit)
Description Gary Benson 2004-06-09 10:10:01 EDT
Description of problem:
Ant does not build servletapi correctly.  A bunch of <copy> tasks do
not occur and the jarfile consequently needs manual fiddling to
correct it.

Version-Release number of selected component (if applicable):
ant-1.5.2-28 (when I beehive it ;))
Comment 1 Gary Benson 2004-06-28 10:52:01 EDT
This affects tomcat too.  It seems to be an error in the processing of
wildcards in <include> directives.

In servletapi, <include name="**/*.properties"/> works but <include
name="web-app*.dtd"/> doesn't. In tomcat <include
name="org/apache/catalina/loader/Extension.class" /> works but     
<include name="org/apache/catalina/loader/StandardClassLoader*.class"
/> doesn't.
        
Comment 2 Gary Benson 2004-06-28 11:18:14 EDT
Created attachment 101469 [details]
Script to exercise the failure
Comment 3 Vadim Nasardinov 2005-11-10 15:45:58 EST
This works for me both in FC4 and rawhide:

|$ curl -o bz125619.sh \
|  'https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=101469'
|  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
|                                 Dload  Upload   Total   Spent    Left  Speed
|100   928  100   928    0     0   1157      0 --:--:-- --:--:-- --:--:--  906k
|$ bash bz125619.sh 
|Buildfile: build.xml
|
|test:
|    [mkdir] Created dir: /tmp/tmp.rCxaD20479/1
|     [copy] Copying 3 files to /tmp/tmp.rCxaD20479/1
|    [mkdir] Created dir: /tmp/tmp.rCxaD20479/2
|     [copy] Copying 1 file to /tmp/tmp.rCxaD20479/2
|    [mkdir] Created dir: /tmp/tmp.rCxaD20479/3
|     [copy] Copying 2 files to /tmp/tmp.rCxaD20479/3
|
|BUILD SUCCESSFUL
|Total time: 4 seconds
|TEST PASSED

Note You need to log in before you can comment on or make changes to this bug.