Bug 1256293 - subscription-manager refresh error on satellite 6 server
subscription-manager refresh error on satellite 6 server
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
6.0.8
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 06:03 EDT by marek.bednarczyk
Modified: 2015-08-24 08:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 08:07:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marek.bednarczyk 2015-08-24 06:03:46 EDT
Description of problem:
subscription-manager refresh gives following error in /var/log/rhsm/rhsm.log

2015-08-24 11:59:11,165 [DEBUG] subscription-manager:3579 @plugins.py:569 - loaded plugin modules: []
2015-08-24 11:59:11,165 [DEBUG] subscription-manager:3579 @plugins.py:570 - loaded plugins: {}
2015-08-24 11:59:11,166 [DEBUG] subscription-manager:3579 @identity.py:131 - Loading consumer info from identity certificates.
2015-08-24 11:59:11,210 [INFO] subscription-manager:3579 @managercli.py:352 - Client Versions: {'python-rhsm': '1.14.3-1.el6', 'subscription-manager': '1.14.10-1.el6'}
2015-08-24 11:59:11,211 [INFO] subscription-manager:3579 @connection.py:727 - Connection built: http_proxy=172.17.152.144:80 host=subscription.rhn.redhat.com port=443 handler=/subscription auth=ide
ntity_cert ca_dir=/etc/rhsm/ca/ verify=False
2015-08-24 11:59:11,211 [INFO] subscription-manager:3579 @connection.py:727 - Connection built: http_proxy=172.17.152.144:80 host=subscription.rhn.redhat.com port=443 handler=/subscription auth=non
e
2015-08-24 11:59:11,228 [DEBUG] subscription-manager:3579 @connection.py:446 - Loaded CA certificates from /etc/rhsm/ca/: redhat-uep.pem, katello-server-ca.pem, candlepin-stage.pem
2015-08-24 11:59:11,228 [DEBUG] subscription-manager:3579 @connection.py:479 - Using proxy: 172.17.152.144:80
2015-08-24 11:59:11,228 [DEBUG] subscription-manager:3579 @connection.py:494 - Making request: GET https://subscription.rhn.redhat.com:443/subscription/
2015-08-24 11:59:12,112 [DEBUG] subscription-manager:3579 @connection.py:521 - Response: status=200
2015-08-24 11:59:12,113 [DEBUG] subscription-manager:3579 @connection.py:744 - Server supports the following resources: {'': '/', 'guestids': '/consumers/{consumer_uuid}/guestids', 'cdn': '/cdn', 'content_overrides': '/consumers/{consumer_uuid}/content_overrides', 'hypervisors': '/hypervisors', 'serials': '/serials', 'deleted_consumers': '/deleted_consumers', 'consumers': '/consumers', 'migrations': '/migrations', 'content': '/content', 'entitlements': '/entitlements', 'events': '/events', 'status': '/status', 'jobs': '/jobs', 'users': '/users', 'subscriptions': '/subscriptions', 'rules': '/rules', 'distributor_versions': '/distributor_versions', 'consumertypes': '/consumertypes', 'statistics/generate': '/statistics/generate', 'pools': '/pools', 'atom': '/atom', 'owners': '/owners', 'roles': '/roles', 'admin': '/admin', 'products': '/products', 'activation_keys': '/activation_keys', 'crl': '/crl'}
2015-08-24 11:59:12,116 [DEBUG] subscription-manager:3579 @connection.py:446 - Loaded CA certificates from /etc/rhsm/ca/: redhat-uep.pem, katello-server-ca.pem, candlepin-stage.pem
2015-08-24 11:59:12,116 [DEBUG] subscription-manager:3579 @connection.py:479 - Using proxy: 172.17.152.144:80
2015-08-24 11:59:12,117 [DEBUG] subscription-manager:3579 @connection.py:494 - Making request: GET https://subscription.rhn.redhat.com:443/subscription/status
2015-08-24 11:59:12,998 [DEBUG] subscription-manager:3579 @connection.py:521 - Response: status=200
2015-08-24 11:59:13,000 [INFO] subscription-manager:3579 @managercli.py:363 - Server Versions: {'rules-version': '5.15', 'candlepin': '0.9.26.11-1', 'server-type': 'Red Hat Subscription Management'}
2015-08-24 11:59:13,000 [INFO] subscription-manager:3579 @managercli.py:328 - Consumer Identity name=satellite.adm.sat uuid=e940eb61-910a-4f9e-8ebf-51810b1a7311
2015-08-24 11:59:13,008 [DEBUG] subscription-manager:3579 @connection.py:446 - Loaded CA certificates from /etc/rhsm/ca/: redhat-uep.pem, katello-server-ca.pem, candlepin-stage.pem
2015-08-24 11:59:13,009 [DEBUG] subscription-manager:3579 @connection.py:479 - Using proxy: 172.17.152.144:80
2015-08-24 11:59:13,010 [DEBUG] subscription-manager:3579 @connection.py:494 - Making request: GET https://subscription.rhn.redhat.com:443/subscription/consumers/e940eb61-910a-4f9e-8ebf-51810b1a7311/certificates/serials
2015-08-24 11:59:14,044 [ERROR] subscription-manager:3579 @managercli.py:160 - Unable to perform refresh due to the following exception:
2015-08-24 11:59:14,045 [ERROR] subscription-manager:3579 @managercli.py:161 -
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 602, in _do_command
    self.entcertlib.update()
  File "/usr/share/rhsm/subscription_manager/certlib.py", line 31, in update
    self.report = self.locker.run(self._do_update)
  File "/usr/share/rhsm/subscription_manager/certlib.py", line 17, in run
    return action()
  File "/usr/share/rhsm/subscription_manager/entcertlib.py", line 43, in _do_update
    return action.perform()
  File "/usr/share/rhsm/subscription_manager/entcertlib.py", line 119, in perform
    expected = self._get_expected_serials()
  File "/usr/share/rhsm/subscription_manager/entcertlib.py", line 254, in _get_expected_serials
    exp = self.get_certificate_serials_list()
  File "/usr/share/rhsm/subscription_manager/entcertlib.py", line 234, in get_certificate_serials_list
    reply = self.uep.getCertificateSerials(identity.uuid)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 1008, in getCertificateSerials
    return self.conn.request_get(method)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 602, in request_get
    return self._request("GET", method)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 512, in _request
    response = conn.getresponse()
  File "/usr/lib64/python2.6/httplib.py", line 1012, in getresponse
    response.begin()
  File "/usr/lib64/python2.6/httplib.py", line 404, in begin
    version, status, reason = self._read_status()
  File "/usr/lib64/python2.6/httplib.py", line 368, in _read_status
    raise BadStatusLine(line)
BadStatusLine


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
see above

Expected results:
refresh works correctly, no errors in rhsm.log

Additional info:
Comment 1 marek.bednarczyk 2015-08-24 06:04:30 EDT
Steps descibed in https://access.redhat.com/solutions/1474003 showed no problems.
Comment 2 marek.bednarczyk 2015-08-24 08:07:52 EDT
The problem solved by itself. There had to be some problems on a network side.

Note You need to log in before you can comment on or make changes to this bug.