Bug 1256339 - dhcrelay execstart parameters trashed after upgrade
dhcrelay execstart parameters trashed after upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 07:47 EDT by Andrew Peek
Modified: 2015-08-27 11:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 11:06:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Peek 2015-08-24 07:47:47 EDT
Description of problem: Inteface and server parameters are lost after dhcrelay version upgrade. Before upgrade dhcrelay.service ExecStart parameters were,

ExecStart=/usr/sbin/dhcrelay -d --no-pid -i eth1 -i eth2 192.168.1.1 192.168.1.2

After upgrade service will not start due to missing server parameter,

ExecStart=/usr/sbin/dhcrelay -d --no-pid

Requires manual intervention to reinstate the missing interface and server parameters after discovering that dhcp clients were not receiving addresses.


Additional info: Upgrade via dnf update, updated version 4.3.3-0.1b1.fc23
Comment 1 Jiri Popelka 2015-08-24 09:19:36 EDT
Had you copied the dhcrelay.service file from /usr/lib/systemd/system/ to /etc/systemd/system/ before editing it ?

www.freedesktop.org/wiki/Software/systemd/FrequentlyAskedQuestions
Comment 2 Andrew Peek 2015-08-24 09:36:04 EDT
No. Sorry I should have mentioned in the bug report that I edited parameters in /etc/systemd/system/multi-user.target.wants/dhcrelay.service which I now see is linked back to /usr/lib/systemd/system/.

Thanks for pointing out the FAQ, I see the error in my ways, new to systemd...

Note You need to log in before you can comment on or make changes to this bug.