Bug 1256491 - [RFE][Tracker] Support snapshot trees
[RFE][Tracker] Support snapshot trees
Status: CLOSED DEFERRED
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
3.5.3
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: Yaniv Lavi
Raz Tamir
: FutureFeature, Tracking
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 14:01 EDT by Amador Pahim
Modified: 2017-11-16 08:43 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-16 08:43:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ykaul: ovirt‑future?
ylavi: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Amador Pahim 2015-08-24 14:01:52 EDT
In current implementation, if we have snapshots "s1 -> s2 -> s3" and preview/commit s1, s2 and s3 will be dropped, as we do not support tree (more then one volume with the same parent).

Since a snapshot is a 'picture' of a given time and it represents a restore point, it should be allowed to revert the disk to any snapshot at any time, without loosing any of the others snapshots.

Please introduce to RHEV the ability to move to any snapshot both backward and forward.
Comment 1 Amador Pahim 2015-08-24 15:48:29 EDT
For the record, here the current implementation of preview/commit:

- No snapshots

  (raw 10G)
------------
| ca8b5daa |
------------
 (active)

- Create S1

  (raw 10G)       (cow)
------------   ------------
| ca8b5daa |---| a116e7d7 |
------------   ------------
                 (active)

- Create S2

  (raw 10G)       (cow)           (cow)
------------   ------------   ------------
| ca8b5daa |---| a116e7d7 |---| 23c187fe |
------------   ------------   ------------
                                 (active)

- Preview S1

  (raw 10G)       (cow)           (cow)
------------   ------------   ------------
| ca8b5daa |---| a116e7d7 |---| 23c187fe |
------------   ------------   ------------
     |
     |            (cow)
     |        ------------
     ---------| 00d83dd2 |
              ------------
                (active)

- Commit S1

  (raw 10G)
------------
| ca8b5daa |
------------
     |            (cow)
     |        ------------
     ---------| 00d83dd2 |
              ------------
                (active)


Notice after "Commit S1", a116e7d7(S2) and 23c187fe(Active) are dropped in favor of the new Active 00d83dd2, created out of S1(ca8b5daa).
Comment 5 Red Hat Bugzilla Rules Engine 2016-01-28 05:18:59 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 6 Red Hat Bugzilla Rules Engine 2016-01-28 05:19:16 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.

Note You need to log in before you can comment on or make changes to this bug.