Bug 1256540 - rhel-osp-director: Re-executed "openstack overcloud update stack --templates -e <yaml> -i overcloud" (after being stopped with ctrl+c) doesn't seem to update the hosts although prints "IN_PROGRESS".
rhel-osp-director: Re-executed "openstack overcloud update stack --templates...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
unspecified
x86_64 Linux
medium Severity medium
: y1
: 8.0 (Liberty)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 17:37 EDT by Alexander Chuzhoy
Modified: 2016-04-18 02:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 17:51:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2015-08-24 17:37:59 EDT
rhel-osp-director:  Re-executed "openstack overcloud update stack --templates  -e <yaml> -i overcloud" (after being stopped with ctrl+c) doesn't seem to update the hosts although prints "IN_PROGRESS".

Environment:
instack-undercloud-2.1.2-23.el7ost.noarch

Steps to reproduce:
1. Deploy an overcloud registered with rhn.
2. Attempt to update it with misconfigured yum files (I actually ran into some issue with rhn).
3. Stop the update with ctrl+c.
4. Re-run the update command "openstack overcloud update stack --templates  -e <yaml> -i overcloud".

Result:

The command doesn't seem to start updating the hosts, although it prints "IN_PROGRESS" in loop.


Expected result:
The update should work as expected.
Comment 3 Zane Bitter 2015-08-24 17:47:13 EDT
Ctrl-C doesn't stop the update, it just kills the client (which is monitoring Heat and clearing breakpoints as it reaches the correct points in the workflow). The output is just the status of the Heat stack, which is still IN_PROGRESS, as it is never stopped.

If we're getting stuck in the IN_PROGRESS state forever because the client is failing to notice that it needs to clear more breakpoints, then that is a bug.

If the problem is simply that the update is not restarting after killing the client and reconnecting, that is expected behaviour.
Comment 4 Alexander Chuzhoy 2015-08-24 17:51:24 EDT
Based on Comment #3 this is the expected behavior (ctrl+c doesn't stop the update).

The BZ for getting stack  IN_PROGRESS is https://bugzilla.redhat.com/show_bug.cgi?id=1256540

Note You need to log in before you can comment on or make changes to this bug.