Bug 125655 - userinfo gives "Unknown error" message
Summary: userinfo gives "Unknown error" message
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: usermode   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-09 19:08 UTC by Chris Lee
Modified: 2013-07-02 23:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 08:45:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Lee 2004-06-09 19:08:16 UTC
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
Using the 'userinfo' tool here at Red Hat, with the NIS and Kerberos 
settings correctly configured, 'userinfo' will prompt me for my 
password and then give me an error message that says simply "Unknown 
error" when attempting to change my user information (shell, office 
number, etc). 
 
This isn't very helpful. At the very least, it should give a more 
descriptive error message; the best case would be fixing the 
userinfo program so that it works. (ypchsh reports that there's no 
yppasswdd running on the NIS master host; could this be the cause of 
the userinfo problem?) 
 
Version-Release number of selected component (if applicable): 
usermode-gtk-1.70-4 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
PREREQUISITE: You must have configured the NIS server settings for 
the internal network here at Red Hat. 
 
1. Run userinfo ("About myself" from the Preferences menu) 
2. Change some information and click 'Apply' 
3. Enter your user account password when prompted, and then view the 
error message. 
     
 
Actual Results:  The error message displayed simply states "Unknown 
error." 
 
Expected Results:  My user information should have been changed, or 
the error message should have explained in more detail why the 
changes could not be saved. 
 
Alternately, the userinfo program could attempt to determine ahead 
of time whether or not changes are possible, and lock the dialog if 
they are not allowed.

Comment 1 Jindrich Novy 2004-09-21 08:45:01 UTC
Chris, it works for me with usermode-1.71-1. Instead of the "Unknown
Error" I get "Information updated.".


Note You need to log in before you can comment on or make changes to this bug.