Bug 125663 - portmap will not uninstall
portmap will not uninstall
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: portmap (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 16:03 EDT by Jeremiah Johnson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 10:46:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremiah Johnson 2004-06-09 16:03:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.2 (KHTML, like Gecko) Safari/125.8

Description of problem:
[root@aegis root]# rpm -e portmap
error reading information on service portmap: No such file or directory
error: %preun(portmap-4.0-59) scriptlet failed, exit status 1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install portmap (which is default even on minimal install)
2. Try to remote portmap
    

Actual Results:  it failed to uninstall

Expected Results:  it should have uninstalled

Additional info:

Venus was in transit yesterday.
Comment 1 Alan Cox 2004-06-19 07:39:26 EDT
Please provide the actual error messages when you try
Comment 2 Jeremiah Johnson 2004-06-19 13:21:22 EDT
[root@aegis root]# rpm -e portmap
error reading information on service portmap: No such file or directory
error: %preun(portmap-4.0-59) scriptlet failed, exit status 1

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
is the actual error message when I try.
Comment 3 Alan Cox 2004-06-19 13:26:54 EDT
rpm -e --noscripts will work around it. Not sure yet what the cause is
Comment 4 Aurelien Bompard 2004-06-21 08:54:19 EDT
In the portmap spec file, there are these lines:
%triggerpostun -- portmap <= portmap-4.0-22
/sbin/chkconfig --add portmap

However, according to RPM's docs, it should be "portmap <= 4.0-22",
just like the Requires syntax. As a consequence, the trigger should
not run for our version, which is 4.0-59, and the problem should not
appear.

For what it's worth, I think that this trigger could be dropped
altogether, since version -22 was shipped before rh70...

This problem is causing much pain to mach, who can't clean up the
buildroot properly most of the time.
Comment 5 Alan Cox 2004-06-21 10:46:48 EDT
Thanks.. fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.