Bug 125665 - Traceback when modifying cluster daemon properties with more than 2 nodes
Traceback when modifying cluster daemon properties with more than 2 nodes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
James Laska
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 16:12 EDT by Derek Anderson
Modified: 2013-09-02 01:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 17:22:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2004-06-09 16:12:24 EDT
Description of problem:
If more than three nodes are defined in a cluster and the user
attempts to modify cluster daemon properties, when clicking OK to
confirm the changes the following traceback occurs and changes are not
saved:

Traceback (most recent call last):
  File
"/usr/share/redhat-config-cluster/configure/daemonPropDialog.py", line
218, in on_okbutton_clicked
    if cluquorumd_pinginterval == "" and
CountMembers(self.clumembd.node) == 2:
NameError: global name 'CountMembers' is not defined

Works fine with only 2 nodes defined.

Version-Release number of selected component (if applicable):
redhat-config-cluster-1.0.2-1.96

How reproducible:
Always

Steps to Reproduce:
1. Create a cluster with 3 nodes
2. Click Cluster -> Configure then Cluster -> Daemon Properties
3. On the clumembd tab change the Failover Speed
4. Click OK
  
Actual results:
Traceback, no changes saved

Expected results:
Change saved

Additional info:
Comment 1 Jim Parsons 2004-06-15 14:59:08 EDT
This has been fixed and checked in. The problem was a typo in the
methiod name...curious this had not been reported before - I suspect
this code path is one not often used.
Comment 2 Derek Anderson 2004-06-15 15:08:07 EDT
Verified in redhat-config-cluster-1.0.2-20 
Comment 3 Mike McLean 2004-06-25 17:22:05 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-254.html

Note You need to log in before you can comment on or make changes to this bug.