Bug 1256671 - Upgrade instructions needs to be updated to disable repositories of previous version with beta repos
Upgrade instructions needs to be updated to disable repositories of previous ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.1.0
Unspecified Unspecified
high Severity high (vote)
: 6.1.2
: 6.1
Assigned To: Peter Ondrejka
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 04:48 EDT by Sachin Ghai
Modified: 2015-11-19 09:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 09:29:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Ghai 2015-08-25 04:48:29 EDT
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Installation_Guide/chap-Upgrading_Red_Hat_Satellite_and_Capsule_Server.html

Section Number and Name: 
Procedure 7.1. Upgrading Red Hat Satellite


Describe the issue: Currently as per docs, we support two upgrade paths:

1. sat6.1 beta to sat6.1.1 GA
2. sat6.0.8 to sat6.1.1 GA

Please note that upgrade instructions are almost same of both paths. However we need to point appropriate subscriptions.

For example:
-----------------
step3 under "Procedure 7.1. Upgrading Red Hat Satellite" is correct only when user is performing upgrade from sat6.0.8 to sat6.1.1

# subscription-manager repos --disable rhel-7-server-satellite-6.0-rpms 


Suggestions for improvement: 

we need update step3 "Disable the repositories for the previous version of Satellite." with:

On sat6.0.8 - Red Hat Enterprise Linux 7
==========================================

# subscription-manager repos --disable rhel-7-server-satellite-6.0-rpms 

On sat6.1 beta  - Red Hat Enterprise Linux 7
==============================================
# subscription-manager repos --disable rhel-server-7-satellite-6-beta-rpms


Similarly, for Red Hat Enterprise Linux 6: 

On sat6.0.8 - Red Hat Enterprise Linux 6
==========================================
# subscription-manager repos --disable rhel-6-server-satellite-6.0-rpms

On sat6.1 beta  - Red Hat Enterprise Linux 6
==============================================
# subscription-manager repos --disable rhel-server-6-satellite-6-beta-rpms


Additional information:
Comment 1 Sachin Ghai 2015-08-25 04:52:17 EDT
Similarly, We need to update following section:

7.2. Upgrading Red Hat Satellite Capsule

Step2: 

On sat6.0.8 - Red Hat Enterprise Linux 7
=========================================

# subscription-manager repos --disable rhel-7-server-satellite-capsule-6.0-rpms 

On sat6.1 beta  - Red Hat Enterprise Linux 7
==============================================
# subscription-manager repos --disable rhel-server-7-satellite-capsule-6-beta-rpms

Similarly, for Red Hat Enterprise Linux 6: 

On sat6.0.8 - Red Hat Enterprise Linux 6
==========================================
# subscription-manager repos --disable rhel-6-server-satellite-capsule-6.0-rpms

On sat6.1 beta  - Red Hat Enterprise Linux 6
==============================================
# subscription-manager repos --disable  rhel-server-6-satellite-capsule-6-beta-rpms
Comment 2 Jitendra Yejare 2015-08-25 06:24:20 EDT
I have some point of updates here,

For Satellite Upgrade:
================================
The section 'The following conditions must be met before upgrading Red Hat Satellite 6:' needs to add following points in case of:
     1) Customer updated existing CV with newly synchronized repos, then:
	 i) Ensure AK is updated with newly synchonized repos.
	ii) Also the subscriptions has to be refreshed with these new repositories on capsules and clients.

    2) Customer created new CV with newly synchronized repos, then:
         i) Ensure AK is updated with this CV.
        ii) Also the subscriptions has to be refreshed with these new repositories on capsules and clients

In both the cases, It is very much important that subscriptions has been refreshed on capsule and client.


For Capsule Upgrade:
===============================
Under Procedure '7.2. Upgrading Red Hat Satellite Capsule',
	i) point 7 and point 8 is not required in case of upgrading from beta. Because the capsule installer will be already installed in beta due to its availability in beta which was not there in 6.0.8.
Comment 3 Peter Ondrejka 2015-09-08 07:33:48 EDT
Hello,

I updated the docs in commit:

https://gitlab.sat.lab.tlv.redhat.com/satellite6-docs/installation-guide/commit/a1ca064317dc4ca7174f059506d6e94602abf8ca

preview at:

http://file.brq.redhat.com/~pondrejk/install-guide/#chap-Red_Hat_Satellite-Installation_Guide-Upgrading_Red_Hat_Satellite_Server_and_Capsule_Server

Sachin, can you please verify? Jitendra, I assume that by AK you mean Activation Key, right?

Thank you
Peter
Comment 4 Sachin Ghai 2015-09-08 07:42:05 EDT
Changes looks good as per comment 1 and original bug description. Thanks Peter.
Comment 5 Jitendra Yejare 2015-09-08 08:06:39 EDT
@Peter, yeah that's correct. By AK I mean Activation Key only.

Note You need to log in before you can comment on or make changes to this bug.