Bug 1256693 - [7.1_3.5.4][ovirt_node]RHEVH TUI crash after setup hosted engine in the case of network disconnection
[7.1_3.5.4][ovirt_node]RHEVH TUI crash after setup hosted engine in the case ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.4
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: Douglas Schilling Landgraf
Huijuan Zhao
node
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 05:32 EDT by Huijuan Zhao
Modified: 2016-01-28 08:26 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 08:26:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEVM configure (12.76 KB, image/png)
2015-08-25 05:34 EDT, Huijuan Zhao
no flags Details

  None (edit)
Comment 1 Huijuan Zhao 2015-08-25 05:34:33 EDT
Created attachment 1066799 [details]
RHEVM configure
Comment 2 Fabian Deutsch 2015-10-19 15:54:51 EDT
Dropping this from a z-stream for now, as it's an unusual flow.
Comment 6 Douglas Schilling Landgraf 2016-01-06 18:27:20 EST
A note about this report, it seems the issue is related to ovirt-node-plugin-vdsm calling vdscli.getVdsCaps() which gets stuck if the network is gone.
Comment 7 Fabian Deutsch 2016-01-20 08:47:52 EST
Douglas, is an exception raised, and can this exception be catched?
Comment 9 Douglas Schilling Landgraf 2016-01-27 08:43:09 EST
(In reply to Fabian Deutsch from comment #7)
> Douglas, is an exception raised, and can this exception be catched?

In my test, I don't see any exception raised, it just stuck.
Comment 10 Fabian Deutsch 2016-01-27 09:19:19 EST
Okay.

Huijuan, can you still reproduce the crash, or is it also just hanging for you?
Comment 11 Huijuan Zhao 2016-01-28 01:33:53 EST
(In reply to Fabian Deutsch from comment #10)
> Okay.
> 
> Huijuan, can you still reproduce the crash, or is it also just hanging for
> you?

Fabian, my test results:
 
Test version:
rhev-hypervisor7-7.2-20160126.0.el7ev
ovirt-node-3.6.1-3.0.el7ev.noarch
20160120.0-1.3.6.ova

Test Steps:
1. Clean install rhev-hypervisor7-7.2-20160126.0.el7ev
2. Setup Network via DHCP
3. Setup hosted engine through ova successfully.
4. Disconnect network
5. Press up/down button in RHEVH TUI
6. Connect network
7. Disconnect network

Actual results:
1. After step5, RHEV-H TUI stuck for more than 2 minutes in “RHEV-M”/"Hosted Engine" page, there is also error message:"Connection closed: Connection timed out".
Wait for more than 2 minutes, the RHEV-H system reboot, after reboot, the TUI still stuck in “RHEV-M”/"Hosted Engine" page for more than 2 minutes.
2. After step6, TUI is normal
3. After step7, the TUI still stuck in “RHEV-M”/"Hosted Engine" page for more than 2 minutes.

Expected results:
After step5/7,the RHEVH TUI should work well.
Comment 12 Fabian Deutsch 2016-01-28 08:26:44 EST
Okay. That situation is even better, because we don't have a crash.

Closing this bug, because no crash appears anymore, and a missing network connection will also cause additional trouble, not just this bug.

Note You need to log in before you can comment on or make changes to this bug.