Bug 1256725 - Failed to pin vm to host and add numa node to vm in one action
Failed to pin vm to host and add numa node to vm in one action
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
All Linux
low Severity high
: ovirt-3.6.1
: ---
Assigned To: Roman Mohr
Artyom
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 06:47 EDT by Artyom
Modified: 2016-04-19 21:11 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The main VM configuration validation was not synchronized with the validation of the numa configuration. Consequence: In some cases the VM configuration validation thought that a numa node configuration was valid although it wasn't. Persisting the numa configuration later on then failed and that part of the configuration was never persisted. Fix: VM validation now executes exactly the same validation like the numa related commands do. Result: VM validation will fail when the numa configuration is invalid. If the validation succeeded persisting the numa configuration will succeed too.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:11:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (1.55 MB, text/plain)
2015-08-25 06:47 EDT, Artyom
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46535 master MERGED core: Fix detection of preferred hosts for numa nodes Never
oVirt gerrit 47606 ovirt-engine-3.6 MERGED core: Fix detection of preferred hosts for numa nodes Never

  None (edit)
Description Artyom 2015-08-25 06:47:30 EDT
Created attachment 1066817 [details]
engine log

Description of problem:
Failed to pin vm to host and add numa node to vm in one action(create, update)

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.12.master.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Have host with Numa Support
2. Create new vm pinned to host and with one numa node
3.

Actual results:
Action failed with error

Expected results:
Action success

Additional info:
If I first pin vm and after create numa node all works fine
Comment 1 Doron Fediuck 2015-08-26 09:21:26 EDT
Since this is actually working when you use 2 actions the prio for
this is low.
Comment 2 Sandro Bonazzola 2015-10-26 08:50:05 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 3 Artyom 2015-11-29 05:51:23 EST
Verified on rhevm-3.6.1-0.2.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.