Bug 1256743 - Cannot install packages using virt-builder because of missing space, even though it was resized before
Cannot install packages using virt-builder because of missing space, even tho...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
: 1288689 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 07:21 EDT by Jan Sedlák
Modified: 2015-12-05 02:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-25 07:55:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Sedlák 2015-08-25 07:21:13 EDT
Description of problem:
When I try to install @Fedora Workstation group using "--install" command, it shows:

virt-builder fedora-22 -o disk_f22_desktop_64bit.img --size 20G --arch x86_64 --run-command "dnf -y remove firewalld*; setarch x86_64 dnf -y update" --selinux-relabel --install "@Fedora Workstation" --root-password password:weakpassword --firstboot-command 'useradd -m -p "" ejohn'
...
Error Summary
-------------
Disk Requirements:
  At least 488MB more space needed on the / filesystem.

virt-builder: error: dnf -y install '@Fedora Workstation': command exited 
with an error

even though I have specified big enough "--size" before. I have tried to increase --size by 10G, but it still shows the same error.

Version-Release number of selected component (if applicable):
virt-builder 1.30.0fedora=22,release=1.fc22,libvirt
Comment 1 Pino Toscano 2015-08-25 07:35:09 EDT
Do you have libguestfs-xfs installed? If not, please install it and try again.
Comment 2 Jan Sedlák 2015-08-25 07:45:04 EDT
Yes, it works with libguestfs-xfs installed.
Comment 4 Richard W.M. Jones 2015-12-05 02:37:03 EST
*** Bug 1288689 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.