Bug 1256765 - TCMS updates again bugzilla with TCMS test case
TCMS updates again bugzilla with TCMS test case
Status: CLOSED NOTABUG
Product: TCMS
Classification: Other
Component: Usability (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Yewei Shao
tools-bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 08:25 EDT by Patrik Kis
Modified: 2015-08-28 09:15 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-28 09:15:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrik Kis 2015-08-25 08:25:31 EDT
Description of problem:
It looks like TCMS started to automatically link test cases to bugzilla again. It was already reported and fixed in bug 1087779, about a year ago. It was agread in the mentioned bug that this feature is not desired.

Version-Release number of selected component (if applicable):
Nitrate 3.8.17

How reproducible:
always

Steps to Reproduce:
It was seen again in bug 1255433.
Comment 1 Ondrej Hudlicky 2015-08-26 11:44:43 EDT
Asking for hotfix this is a Regression with high impact
- breaking established QE workflows (Regression)
- no workaround except not linking found issues to test runs
- messing Bugzilla data, hundreds of bugs were incorrectly updated, users spammed
Comment 2 Patrik Kis 2015-08-27 03:57:25 EDT
The issue was also seen in bug 1245279
Comment 3 jianchen 2015-08-27 23:18:19 EDT
Actually, the "link test case" only happened when user manually check the checkbox in WebUI. We have updated TCMS settings and disabled this feature.
Comment 4 jianchen 2015-08-28 05:16:50 EDT
After checked all history and now we can confirm it's not a regression. 

Here is the timeline:
  a.  BZ#769271 from QE reported a feature to add TCMS test case to BZ.
  b.  We released the feature in TCMS 3.8.0 on Jul 2012
  c.  QE from other teams reported that the feature cause problems, they don’t want the feature.
  d.  We disabled the feature as quick fix. Then we enabled the feature and added a check box “Check to add Test Cases to BZ”, by default it is unchecked. It was released in TCMS 3.8.8 in July 2014.
  e. Nothing changed after it. If QE check the box to add Test Cases to BZ, it should not be a TCMS bug.
Comment 5 jianchen 2015-08-28 05:33:50 EDT
(In reply to Ondrej Hudlicky from comment #1)
> Asking for hotfix this is a Regression with high impact
> - breaking established QE workflows (Regression)

How "External Trackers" breaking the workflows?

> - no workaround except not linking found issues to test runs

Found issues was default unlink to test runs, only when user manually check the "link" checkbox.

> - messing Bugzilla data, hundreds of bugs were incorrectly updated, users
> spammed
As mentioned above, bugs only updated when user manually checked check the "link" checkbox.
Comment 6 Victor Chen 2015-08-28 09:15:00 EDT
Got confirmation from Patrik, we could close the bug now.

[28][21:08]  <pkis|wfh> I have responce
[28][21:08]  <pkis|wfh> response
[28][21:08]  <pkis|wfh> he checked the checkboc
[28][21:09]  <pkis|wfh> checkbox, so this is not regression
[28][21:09]  <pkis|wfh> and the bug can be closed
[28][21:09]  <pkis|wfh> sorry for the confusion
[28][21:13]  <vchen> pkis|wfh, no problem. thx a lot for the confirmation. :)
Comment 7 Patrik Kis 2015-08-28 09:15:33 EDT
(In reply to jianchen from comment #4)
> After checked all history and now we can confirm it's not a regression. 
> 
> Here is the timeline:
>   a.  BZ#769271 from QE reported a feature to add TCMS test case to BZ.
>   b.  We released the feature in TCMS 3.8.0 on Jul 2012
>   c.  QE from other teams reported that the feature cause problems, they
> don’t want the feature.
>   d.  We disabled the feature as quick fix. Then we enabled the feature and
> added a check box “Check to add Test Cases to BZ”, by default it is
> unchecked. It was released in TCMS 3.8.8 in July 2014.
>   e. Nothing changed after it. If QE check the box to add Test Cases to BZ,
> it should not be a TCMS bug.

It looks like the test case was added via the checkbox option by my co-worker.
And because I newer noticed the checkbox, I immediately suspected that TCMS linked the test to bug automatically.
So this is not a regression and is neither a bug. It can be closed; sorry for confusion and caused troubles.

Note You need to log in before you can comment on or make changes to this bug.