Bug 125678 - pdksh fails to add /usr/bin/ksh to /etc/shells
pdksh fails to add /usr/bin/ksh to /etc/shells
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pdksh (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 18:43 EDT by Richard Lloyd
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-19 09:05:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Lloyd 2004-06-09 18:43:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.6) Gecko/20040116

Description of problem:
When the pdksh RPM is installed from the Fedora Core 2 media, it
creates not only the /bin/ksh binary and /bin/ksh entry in
/etc/shells, but also adds a /usr/bin/ksh soft-link to ../../bin/ksh
(aka /bin/ksh).
That /usr/bin/ksh soft-link is not, however, added to /etc/shells.

Version-Release number of selected component (if applicable):
pdksh-5.2.14-24

How reproducible:
Always

Steps to Reproduce:
1. Install the pdksh RPM from the Fedora Core 2 install media.
2. Confirm that /bin/ksh (binary) and /usr/bin/ksh (soft-link) are
installed.

Actual Results:  If you look at /etc/shells, you will see that only
/bin/ksh has been added to /etc/shells.

Expected Results:  *Both* /bin/ksh and /usr/bin/ksh should be added to
/etc/shells. The fact that /usr/bin/ksh is a "legacy" soft-link is
irrelevant because you are allowed to "useradd -s /usr/bin/ksh" after
installing pdksh.

Additional info:

On commercial UNIXes such as HP-UX, ksh is (ironically) present in
/usr/bin/ksh. For HP-UX, it's the directory /bin itself that is
soft-linked to /usr/bin and that creates both /bin/ksh and
/usr/bin/ksh availability - and, yes, /etc/shells on HP-UX has both
/bin/ksh and /usr/bin/ksh.
Comment 1 Alan Cox 2004-06-19 09:05:26 EDT
Fixed in cvs

Note You need to log in before you can comment on or make changes to this bug.