Bug 125679 - Empty messages in syslog caused by "don't escape UTF-8"
Empty messages in syslog caused by "don't escape UTF-8"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sysklogd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 126931 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 18:47 EDT by Robert Scheck
Modified: 2014-03-16 22:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-20 04:10:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-06-09 18:47:19 EDT
Description of problem:
After installing the latest ksyslogd I got the following in 
/var/log/messages:

--- snipp ---
Jun  9 19:32:52 hurricane kernel: Kernel logging (proc) stopped.
Jun  9 19:32:52 hurricane kernel: Kernel log daemon terminating.
Jun  9 19:32:53 hurricane syslog: Herunterfahren von klogd succeeded
Jun  9 19:32:55 hurricane exiting on signal 15
Jun  9 19:32:58 hurricane syslogd 1.4.1: restart.
Jun  9 19:32:58 hurricane
Jun  9 19:33:42 hurricane last message repeated 3 times
Jun  9 19:33:42 hurricane
Jun  9 19:33:44 hurricane exiting on signal 15
Jun  9 19:33:45 hurricane syslogd 1.4.1: restart.
Jun  9 19:33:45 hurricane
Jun  9 19:33:45 hurricane last message repeated 2 times
Jun  9 19:33:46 hurricane
Jun  9 19:33:47 hurricane
Jun  9 19:51:26 hurricane
Jun  9 20:34:31 hurricane last message repeated 2 times
Jun  9 22:27:08 hurricane
Jun  9 23:01:34 hurricane
Jun  9 23:01:34 hurricane
Jun  9 23:01:56 hurricane
Jun  9 23:01:56 hurricane
Jun  9 23:02:01 hurricane
Jun  9 23:02:11 hurricane
Jun  9 23:02:11 hurricane
Jun  9 23:04:04 hurricane
Jun  9 23:04:05 hurricane
Jun  9 23:41:52 hurricane
Jun  9 23:48:17 hurricane
Jun 10 00:14:47 hurricane
Jun 10 00:38:21 hurricane
Jun 10 00:39:35 hurricane last message repeated 2 times
Jun 10 00:39:36 hurricane last message repeated 2 times
--- snapp ---

Doesn't look very nice, especially the empty messages, because
there should be real messages of daemons (I restarted httpd and 
sshd for example).

Version-Release number of selected component (if applicable):
sysklogd-1.4.1-17

How reproducible & Steps to Reproduce:
1. Default charset systemwide is NON-UTF8 (for example iso-8859-1)
2. Install sysklogd
3. Restart a daemon
4. Get the empty messages in syslog
[5. Do the fallback to -16 to get something working]

Actual results:
I still know, that UTF8 is Red Hat's default, but maybe we can find
a solution to make both working fine? 

Expected results:
Solution where UTF8 and other charsets without conflicts and problems
are working in syslog without empty messages or something like that 
:-)
Comment 1 Ville Herva 2004-06-17 13:00:57 EDT
*** Bug 126216 has been marked as a duplicate of this bug. ***
Comment 2 Pekka Pietikäinen 2004-06-19 18:34:02 EDT
*** Bug 125650 has been marked as a duplicate of this bug. ***
Comment 3 Nicolas Mailhot 2004-06-20 03:54:26 EDT
FYI I had this on a system with an UTF-8 locale too
Comment 4 Nicolas Mailhot 2004-06-20 03:59:20 EDT
Please mark this a 125650 instead of the reverse, since 
- 125650 is older
- it has a *long* list of people in CC (including RH people)
- it is the one referenced on fedora-devel mailing list.

Alternatively please at least transfer all the CCs from 125650 to this one
Comment 5 Florian La Roche 2004-06-20 04:10:53 EDT
Next rpm should have this fixed, will just copy all non '\n'-chars
for now...
Comment 6 Robert Scheck 2004-06-20 07:32:19 EDT
Thank you very much, Florian, your fix works very well for me :-)
Comment 7 Reuben Farrelly 2004-06-21 02:42:33 EDT
Works well here too.  Thanks :)
Comment 8 Bill Nottingham 2004-06-29 01:03:17 EDT
*** Bug 126452 has been marked as a duplicate of this bug. ***
Comment 9 Bill Nottingham 2004-06-29 14:42:17 EDT
*** Bug 126931 has been marked as a duplicate of this bug. ***
Comment 10 Jason Vas Dias 2004-08-25 14:59:04 EDT
*** Bug 130905 has been marked as a duplicate of this bug. ***
Comment 11 Tim Powers 2005-05-19 19:18:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-087.html

Note You need to log in before you can comment on or make changes to this bug.