Bug 1256793 - net join to samba domain fails
net join to samba domain fails
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Andreas Schneider
qe-baseos-daemons
: Regression
Depends On:
Blocks: 1246125
  Show dependency treegraph
 
Reported: 2015-08-25 08:56 EDT by Patrik Kis
Modified: 2015-09-02 09:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Please update Doc Text for RHEL7.2 Beta release notes Cause: Consequence: Workaround (if any): Result:
Story Points: ---
Clone Of: 1172089
Environment:
Last Closed: 2015-09-02 07:25:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrik Kis 2015-08-25 08:56:32 EDT
It looks like this bug appeared again.
The symptoms are exactly the same as below; the samba version is:
samba-4.2.3-6.el7
but it was reproduced also with
samba-4.2.2-1.el7
The last version where the issue is not appearing is:
samba-4.1.12-22.el7

See the original bug for more details and for the reproducer.

+++ This bug was initially created as a clone of Bug #1172089 +++

Description of problem:
samba join to samba domain doesn't work

Failed to join domain: Machine is a Domain Controller
:: [   FAIL   ] :: Command 'net join --domain QAB3QGC -U nbusr%nbusr123' (Expected 0, got 255)

It is a regression, the same use case passed with samba-4.1.12-3.el7

Version-Release number of selected component (if applicable):
samba-4.1.12-4.el7

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
Failed to join domain: Machine is a Domain Controller
:: [   FAIL   ] :: Command 'net join --domain QAB3QGC -U nbusr%nbusr123' (Expected 0, got 255)

Expected results:
Joined domain QAB3QGC.
:: [   PASS   ] :: Command 'net join --domain QAB3QGC -U nbusr%nbusr123' (Expected 0, got 0)
Comment 2 Andreas Schneider 2015-08-25 10:09:45 EDT
What is the output of 'testparm -s' on the machine.

Can you run 'net ads join' with -d10 and post the output?
Comment 3 Robin Hack 2015-08-25 10:12:06 EDT
QA_ACK+
Comment 6 Andreas Schneider 2015-09-01 07:57:07 EDT
You have a AD DC and the smb.conf doesn't have the realm set for the AD DC ...
Comment 7 Andreas Schneider 2015-09-02 07:14:23 EDT
Well, you are trying to join a PDC (NT4-style domain controller) do and AD DC. You can't join a domain controller as a member server ...
Comment 8 Andreas Schneider 2015-09-02 07:16:00 EDT
What are you trying to test?
Comment 9 RHEL Product and Program Management 2015-09-02 07:25:39 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 10 Patrik Kis 2015-09-02 09:36:41 EDT
(In reply to Andreas Schneider from comment #8)
> What are you trying to test?

Actually freeradius and samba integration, but for the purpose of this test this join is not needed. It was just added there for no particular reason and since it started to fail I reported it. I thought it is a sane operation, especially as it was already once reported in bug 1172089. The test was already fixed. Thanks for clarifying this and sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.