Bug 1256811 - Reference Area for how OpenShift uses Kubernetes. etcd. and docker differently than default
Reference Area for how OpenShift uses Kubernetes. etcd. and docker differentl...
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Vikram Goyal
Bilhar
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 09:41 EDT by Ryan Howe
Modified: 2016-08-19 14:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 02:55:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-08-25 09:41:35 EDT
Document URL: https://docs.openshift.com/enterprise/3.0/welcome/index.html

Section Number and Name: New Section

Describe the issue: When administrating OSEv3 it is very hard to refer to etcd, kubernetes, and docker documentation to troubleshoot issues. Since OSEv3 is a wrapper for these products and changes configuration file location and commands it would be useful to have a reference doc that explains what files and commands osev3 uses that relate to etcd, kubernetes, and docker 

Suggestions for improvement: 

A reference to what OSEv3 changed vs the default locations for files, configs, and commands for etcd, kubernetes, and docker 


Additional information:
Comment 3 Bilhar 2015-08-27 00:42:14 EDT
Ryan, would we be better off creating some sort of a Troubleshooting/Diagnostics document for OSE v3 for our customers so that they don't have to refer to any external Kubernetes/Docker documentation? I'm thinking from the customer's perspective that may be a better route. If have already or if we can collect that information, and we have enough issues to document then that may provide more value for our customers.

The troubleshooting doc should contain all log files and commands our customers can use to resolve some of these issues.

I imagine we can still investigate developing some sort of a reference document at some stage, but maybe for starters we provide the troubleshooting doc to help our customers.
Comment 4 Vikram Goyal 2015-09-03 02:55:20 EDT
@Ryan @Bilhar - we discussed this in the meeting the other day and a tracker bug was created: https://bugzilla.redhat.com/show_bug.cgi?id=1259118.

I am going to close this bug and will put a reference to it from the tracker bug.

Note You need to log in before you can comment on or make changes to this bug.