Bug 1256906 - Pop-up window with numbers jumps when trying to select a number
Pop-up window with numbers jumps when trying to select a number
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-sudoku (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Yanko Kaneti
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 13:20 EDT by Steven Usdansky
Modified: 2015-09-09 21:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 21:24:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Usdansky 2015-08-25 13:20:21 EDT
Description of problem:
The pop-up window containing the numbers jumps from its initial position when trying to select a number.

Version-Release number of selected component (if applicable):
gnome-sudoku-1:3.17.2-2.fc23
gnome-sudoku-3.17.90-1.fc23
gnome-sudoku-3.17.90-1.fc24 (current rawhide)

How reproducible: 100%


Steps to Reproduce:
1. Start gnome-sudoku
2. Left or right click on an empty cell
3. Move mouse in an attempt to click on a number that appears in the pop-up window

Actual results:
Window jumps as mouse cursor departs from click position

Expected results:
Window stays put until number is clicked or window is dismissed

Additional info:
Comment 1 Yanko Kaneti 2015-08-26 03:14:02 EDT
I figure this might be another "not under stock gnome" setup because I can't reproduce it. Tried under gnome-shell, fvwm, gnome on wayland(where there is another bug, but not that one)

What Desktop environment/WM are you using?
Comment 2 Steven Usdansky 2015-09-09 21:24:19 EDT
DE = Mate; WM = Marco

Current (09-Sep) Rawhide with 
  gnome-sudoku-3.17.90-1.fc24.x86_64
  gtk3-3.17.8-1.fc24.x86_64
works properly. There is still a small adjustment, but the adjustment now occurs immediately when the popup number pad appears, well before I can move my cursor onto any of the numbers on the number pad. I haven't played sudoku in F23, in the past two weeks, but it too is updated to gnome-sudoku-3.17.90-1 and gtk3-3.17.8-1. I figure if the problem still exists there, it's not with gnome-sudoku, so marking the bug CLOSED  CURRENT RELEASE.

Note You need to log in before you can comment on or make changes to this bug.