Bug 1257002 - [abrt] yumex-dnf: shutil.py:109:copyfile:FileNotFoundError: [Errno 2] No such file or directory: '/home/henry/.config/autostart/yumex-dnf.desktop'
[abrt] yumex-dnf: shutil.py:109:copyfile:FileNotFoundError: [Errno 2] No such...
Status: CLOSED DUPLICATE of bug 1225518
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:0ffbcf5b8f5f7397b43f0ac0c6f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 23:58 EDT by Dan Mossor [danofsatx]
Modified: 2016-02-14 16:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 09:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.43 KB, text/plain)
2015-08-25 23:58 EDT, Dan Mossor [danofsatx]
no flags Details
File: environ (1.44 KB, text/plain)
2015-08-25 23:58 EDT, Dan Mossor [danofsatx]
no flags Details

  None (edit)
Description Dan Mossor [danofsatx] 2015-08-25 23:58:55 EDT
Description of problem:
Yumex > Preferences.
Start status icon at user login: on
Scheduled check for new updates: on
* Update check interval (minutes): 60 (default)
* Update checker startup delay (seconds): 30 (default)
Show notification when updates are found: on
Show status icon when no updates are found: off

Set up yumex to show an indicator on login and when updates are available. When I closed the yumex settings window, the bug catcher popped up.

Going back in to the preferences again to generate the text for this BZ, I found that the scheduled check for new updates was off, but the status icon, show notification when updates found and show status icon when when no updates are found were all off.

The directory ~/.config/autostart does not exist on F23 Cinnamon, and yumex didn't create it.

Version-Release number of selected component:
yumex-dnf-4.1.3-2.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -tt /usr/bin/yumex-dnf
executable:     /usr/bin/yumex-dnf
kernel:         4.2.0-0.rc8.git0.1.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
shutil.py:109:copyfile:FileNotFoundError: [Errno 2] No such file or directory: '/home/henry/.config/autostart/yumex-dnf.desktop'

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/yumex/__init__.py", line 969, in on_pref
    need_reset = self.preferences.run()
  File "/usr/lib/python3.4/site-packages/yumex/gui/dialogs.py", line 74, in run
    need_reset = self.set_settings()
  File "/usr/lib/python3.4/site-packages/yumex/gui/dialogs.py", line 139, in set_settings
    self.handle_setting(option, state)
  File "/usr/lib/python3.4/site-packages/yumex/gui/dialogs.py", line 177, in handle_setting
    "/.config/autostart/yumex-dnf.desktop")
  File "/usr/lib64/python3.4/shutil.py", line 229, in copy
    copyfile(src, dst, follow_symlinks=follow_symlinks)
  File "/usr/lib64/python3.4/shutil.py", line 109, in copyfile
    with open(dst, 'wb') as fdst:
FileNotFoundError: [Errno 2] No such file or directory: '/home/henry/.config/autostart/yumex-dnf.desktop'

Local variables in innermost frame:
dst: '/home/henry/.config/autostart/yumex-dnf.desktop'
fsrc: <_io.BufferedReader name='/usr/share/yumex-dnf/yumex-dnf-autostart.desktop'>
src: '/usr/share/yumex-dnf/yumex-dnf-autostart.desktop'
st: os.stat_result(st_mode=33188, st_ino=923568, st_dev=64768, st_nlink=1, st_uid=0, st_gid=0, st_size=200, st_atime=1440386995, st_mtime=1434692076, st_ctime=1440386995)
follow_symlinks: True
fn: '/home/henry/.config/autostart/yumex-dnf.desktop'
Comment 1 Dan Mossor [danofsatx] 2015-08-25 23:58:57 EDT
Created attachment 1067113 [details]
File: backtrace
Comment 2 Dan Mossor [danofsatx] 2015-08-25 23:58:58 EDT
Created attachment 1067114 [details]
File: environ
Comment 3 Tim Lauridsen 2015-10-06 09:20:02 EDT
Fixed in 4.1.4

https://bodhi.fedoraproject.org/updates/FEDORA-2015-816c17411d
Comment 4 Tim Lauridsen 2015-10-06 09:25:46 EDT

*** This bug has been marked as a duplicate of bug 1225518 ***

Note You need to log in before you can comment on or make changes to this bug.