Bug 1257200 - virt-xml-validate fails for openstack instance
virt-xml-validate fails for openstack instance
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 09:11 EDT by Timofey Durakov
Modified: 2015-08-31 06:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 06:14:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
domain xml dump (2.84 KB, text/plain)
2015-08-26 09:11 EDT, Timofey Durakov
no flags Details

  None (edit)
Description Timofey Durakov 2015-08-26 09:11:41 EDT
Created attachment 1067254 [details]
domain xml dump

Description of problem:


Version-Release number of selected component (if applicable):
1.2.2

How reproducible:
always

Steps to Reproduce:
1. deploy devstack
2. start instance
3. validate xml of newly created instance

Actual results:
stack@node2:/opt/stack/data/nova/instances/e6817eb9-0af6-4265-b77c-d0a4df79c1a8$ virt-xml-validate libvirt.xml 
Relax-NG validity error : Extra element cpu in interleave
libvirt.xml:53: element cpu: Relax-NG validity error : Element domain failed to validate content
libvirt.xml fails to validate

Expected results:
domain.xml validates


Additional info:
Comment 1 Ján Tomko 2015-08-31 06:14:52 EDT
Fixed upstream by:
commit adff345e1ec9a6f528731ae40168a76b8e7620e0
Author:     Martin Kletzander <mkletzan@redhat.com>
AuthorDate: 2015-01-05 17:03:58 +0100
Commit:     Martin Kletzander <mkletzan@redhat.com>
CommitDate: 2015-01-13 08:51:01 +0100

    qemu: Allow enabling/disabling features with host-passthrough
    
    QEMU supports feature specification with -cpu host and we just skip
    using that.  Since QEMU developers themselves would like to use this
    feature, this patch modifies the code to work.
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1178850
    
    Signed-off-by: Martin Kletzander <mkletzan@redhat.com>

git describe: v1.2.11-143-gadff345 contains: v1.2.12-rc1~66

commit dfc708750bb62cabd4617f3c0cf29beb27f28c28
Author:     Eric Blake <eblake@redhat.com>
AuthorDate: 2015-03-26 16:48:07 -0600
Commit:     Eric Blake <eblake@redhat.com>
CommitDate: 2015-03-26 16:57:26 -0600

    relaxng: allow : in /dev/disk/by-path names
    
    On IRC, Hydrar pointed a problem where 'virsh edit' failed on
    his domain created through an ISCSI pool managed by virt-manager,
    all because the XML included a block device with colons in the
    name.
    
    * docs/schemas/basictypes.rng (absFilePath): Add colon as safe.
    * tests/qemuxml2argvdata/qemuxml2argv-disk-iscsi.xml: New file.
    * tests/qemuxml2argvdata/qemuxml2argv-disk-iscsi.args: Likewise.
    * tests/qemuxml2argvtest.c (mymain): Test it.
    
    Signed-off-by: Eric Blake <eblake@redhat.com>

git describe: v1.2.14-rc1 contains: v1.2.14-rc1^0

Note You need to log in before you can comment on or make changes to this bug.