Bug 1257245 - pki-core source rebuilding generates pki-ocsp, pki-tks, pki-tps and pki-javadoc
pki-core source rebuilding generates pki-ocsp, pki-tks, pki-tps and pki-javadoc
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Matthew Harmsen
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 11:00 EDT by Kaushik Banerjee
Modified: 2016-01-06 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 16:42:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaushik Banerjee 2015-08-26 11:00:31 EDT
Description of problem:
Rebuilding from source generates pki-ocsp, pki-tks, pki-tps and pki-javadoc which are not to be shipped for 7.2.
This leads to tps error as discussed in https://engineering.redhat.com/rt/Ticket/Display.html?id=367981

Version-Release number of selected component (if applicable):
10.2.5-4.el7

How reproducible:
Always. But only in source.

Steps to Reproduce:
1. tps-srpmtest throws the following error:

TPSERROR: pki-ocsp-10.2.5-4.el7.noarch.rpm was built by
pki-core-10.2.5-4.el7.src.rpm but not included in the file list
Please check previously released packages to ensure the file list
is sane. It is possible that the new-files list is incomplete, perhaps
due to some problem with Release Engineering's ComposeDB, or perhaps due
to a new subpackage. In that case, please file an RT ticket with
release-engineering@redhat.com. After RelEng makes the update, reload
the filelist for the affected brew build.
It is also possible that the .spec file is consuming time and
resources by building something we do not intend to ship; in this case,
file a bug against the package to correct that behavior.
/mnt/redhat/released, tps-check-channels, RHN, and previous
advisories are all sources of information about previously released
packages.
TPSERROR: pki-tks-10.2.5-4.el7.noarch.rpm was built by
pki-core-10.2.5-4.el7.src.rpm but not included in the file list
TPSERROR: pki-tps-10.2.5-4.el7.x86_64.rpm was built by
pki-core-10.2.5-4.el7.src.rpm but not included in the file list
TPSERROR: pki-javadoc-10.2.5-4.el7.noarch.rpm was built by
pki-core-10.2.5-4.el7.src.rpm but not included in the file list
end test at Tue Aug 11 10:55:52 EDT 2015 on
ibm-x3250m4-04.lab.eng.rdu2.redhat.com
TPSRESULT: REBUILD: pki-core-10.2.5-4.el7.src.rpm for x86_64
Returning: FAIL

2.
3.

Actual results:
tps-srpmtest fails because pki-ocsp, pki-tks, pki-tps and pki-javadoc are being built

Expected results:
pki-ocsp, pki-tks, pki-tps and pki-javadoc should not be built from the source for rhel7.2

Additional info:
Comment 2 Nathan Kinder 2015-08-31 17:01:10 EDT
This is by design, and isn't changing any time soon.  All of the subsystems need to be built from a common source to work together.  Pushing to 7.3 so we can discuss how to make this less painful for TPS.
Comment 4 Matthew Harmsen 2016-01-06 16:42:53 EST
Per discussions in the RHEL 7.3 Triage meeting of 01/06/2016: CLOSED WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.