Bug 125734 - usb audio and alsa snd-usb-audio module conflict
Summary: usb audio and alsa snd-usb-audio module conflict
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
: 123261 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-10 18:23 UTC by oreilly
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 16:03:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description oreilly 2004-06-10 18:23:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
As noted on the alsa docs for usb audio devices:
http://www.alsa-project.org/alsa-doc/doc-php/template.php?module=usb-audio
you can't have both the "old" usb system audio.o module and the "new" alsa snd-usb-audio.o module loaded at the same time, because audio.o preempts use of the alsa driver.

However, FC2 is loading the audio.o driver during the boot process.
I could not figure out how to prevent this, but presumably someone there knows how to do this, and it should be done otherwise any usb audio device is essentially unusable in the system given that it is using alsa.

This is also a problem for kudzu, which generates the wrong entries in /etc/modprobe.conf, specifying the old audio driver instead of the snd-usb-audio driver.  Note that the above problem persists even when modprobe.conf is fixed to specify snd-usb-audio.

Version-Release number of selected component (if applicable):
hotplug-2004_04_01-1

How reproducible:
Always

Steps to Reproduce:
1. attach a usb audio device, configure it with kudzu
2. fix /etc/modprobe.conf to specify snd-usb-audio instead of audio
3. reboot
    

Actual Results:  cat /proc/asound/cards etc does not specify the device
lsmod shows that audio module is loaded.

Expected Results:  cat /proc/acound/cards should show the audio device, it should show up in the mixer, etc

Additional info:

Comment 1 Bill Nottingham 2004-06-28 22:17:20 UTC
We should turn off the old audio driver...

Comment 2 Bill Nottingham 2004-07-14 16:03:11 UTC
*** Bug 123261 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2004-07-14 16:03:40 UTC
Should be fixed in future kernel builds (2.6.7-1.470 or so).

Comment 4 Nils O. Selåsdal 2004-08-01 01:43:14 UTC
Might this be why I can't get my USB headset working with ALSA(FC2) ?
It works with OSS emulation through /dev/dsp1, but not through alsa.

Comment 5 Bill Nottingham 2004-08-02 19:38:14 UTC
Very likely, yes.


Note You need to log in before you can comment on or make changes to this bug.