Bug 125737 - setools Makefile has incorrect policy install location defined
Summary: setools Makefile has incorrect policy install location defined
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: setools   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-10 18:35 UTC by Don Patterson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-30 19:38:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix setools Makefile to correctly locate compiled policy (764 bytes, patch)
2004-06-10 18:37 UTC, Don Patterson
no flags Details | Diff

Description Don Patterson 2004-06-10 18:35:39 UTC
Description of problem:
The top-level Makefile in the setools-1.4 package uses an incorrect 
hardcoded policy install path for the strict policy.  

Version-Release number of selected component (if applicable):
setools-1.4

How reproducible:
[root@new2 root]# seinfo

Steps to Reproduce:
1. execute seinfo with no arguments.
2.
3.
  
Actual results:
Could not open policy /etc/selinux/strict/policy.17!
search_for_policyfile_with_ver: No such file or directory Error while 
searching for default policy: Error in find_default_policy_file().

Expected results:
Should be looking for the compiled binary 
file /etc/selinux/strict/policy/policy.17 instead 
of /etc/selinux/strict/policy.17.

Additional info:
This error should be handled more gracefully and will be fixed in the 
next release.

Comment 1 Don Patterson 2004-06-10 18:37:24 UTC
Created attachment 101043 [details]
Patch to fix setools Makefile to correctly locate compiled policy

Comment 2 Daniel Walsh 2004-06-23 21:59:52 UTC
setools-1_4-4 has fix

Comment 3 Don Patterson 2004-06-30 19:37:33 UTC
setools-1_4-4_ works for me. Thanks.


Note You need to log in before you can comment on or make changes to this bug.