Bug 1257529 - job monitoring don't work as expected
job monitoring don't work as expected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Moti Asayag
Raz Tamir
: Automation, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 05:36 EDT by Raz Tamir
Modified: 2016-04-19 21:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:39:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (559.74 KB, text/plain)
2015-08-27 05:36 EDT, Raz Tamir
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47444 master MERGED engine: Remove snapshot job remains open Never
oVirt gerrit 47446 ovirt-engine-3.6 MERGED engine: Remove snapshot job remains open Never
oVirt gerrit 47456 ovirt-engine-3.6.0 MERGED engine: Remove snapshot job remains open Never

  None (edit)
Description Raz Tamir 2015-08-27 05:36:47 EDT
Created attachment 1067616 [details]
engine log

Description of problem:
In many cases the job monitoring "reset" jobs that already finished and move them to status started - See this behavior via the UI.
In DB all seems to be fine (All jobs are finished)

* The most common job is when moving disk to other SD


Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.12.master.el6.noarch

How reproducible:
90%

Steps to Reproduce:
1. create vm woth disk
2. Move the disk to second SD
3.

Actual results:


Expected results:


Additional info:
In the logs - around 11:57:42
Comment 1 Raz Tamir 2015-08-27 06:30:44 EDT
Another jobs is removing snapshot
Comment 2 Oved Ourfali 2015-08-30 01:01:37 EDT
Moti, I guess it is the same issue we're working on.
Comment 3 Moti Asayag 2015-08-30 01:53:30 EDT
(In reply to Oved Ourfali from comment #2)
> Moti, I guess it is the same issue we're working on.

Indeed, this was solved by [1] and is another aspect of Bug 1248090

[1] https://gerrit.ovirt.org/#/c/45008/
Comment 5 Raz Tamir 2015-10-08 09:44:44 EDT
Still occurs.
job 'Removing Snapshot .* of VM .*' still stuck
Comment 6 Moti Asayag 2015-10-18 09:06:08 EDT
(In reply to ratamir from comment #1)
> Another jobs is removing snapshot

This scenario reproduced only for removing a snapshot of a running vm (with or without saving memory).

It seems that the Command Coordinator somehow nullify the job id associated with the action, which lead the command's context to fail in closing the job.
Comment 7 Raz Tamir 2015-11-10 07:52:05 EST
Verified on rhevm-3.6.0.3-0.1.el6.noarch (3.6.0-18)

Remove snapshot task marked as FINISHED after it completed

Note You need to log in before you can comment on or make changes to this bug.