Bug 1257538 - Upon a reboot file route-lo is *not* honoured
Upon a reboot file route-lo is *not* honoured
Status: ASSIGNED
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts (Show other bugs)
7.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 05:52 EDT by Mario Mikocevic
Modified: 2017-10-31 07:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Mikocevic 2015-08-27 05:52:16 EDT
Description of problem:

Server reboot does not activate lines from route-lo, however lines from rule-lo are activated.

Version-Release number of selected component (if applicable):
initscripts-9.49.24-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:

/etc/sysconfig/network-scripts/ifcfg-lo
IPADDR1=PUBLIC_IP
PREFIX1=32

/etc/sysconfig/network-scripts/rule-lo
pref 30 from PUBLIC_IP table 30

/etc/sysconfig/network-scripts/route-lo
default table 30
  nexthop via ENO1_IP dev eno1 weight 10
  nexthop via ENO2_IP dev eno2 weight 10
(multilined for posterity)


after a reboot rule lines are active, route lines are not

Note You need to log in before you can comment on or make changes to this bug.