Bug 125761 - module pg.py looks for libpq.so.2
module pg.py looks for libpq.so.2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-10 18:11 EDT by Andrew B. Young
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-10 18:20:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew B. Young 2004-06-10 18:11:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040608 Firefox/0.8.0+

Description of problem:
After loading "Everything" from the release and trying a cgi I get--
-------------------------------------
|   11 import iolon.Customer
|
| /usr/lib/python2.3/site-packages/iolon/Customer.py
|    9 import pg
|
| /usr/local/lib/python2.3/site-packages/pg.py
|    8 from _pg import *
|
|ImportError: libpq.so.2: cannot open shared object file: No such file
|or directory
|      args = ('libpq.so.2: cannot open shared object file: No such
file |or directory',)

I looks like I've got--
/usr/lib/libpq.a
/usr/lib/libpq.so
/usr/lib/libpq.so.3
/usr/lib/libpq.so.3.1
[

Version-Release number of selected component (if applicable):
python-devel-2.3.3-6

How reproducible:
Always

Steps to Reproduce:
1. Try to run a script that used pg.py
2.
3.
    

Additional info:

Note You need to log in before you can comment on or make changes to this bug.