Bug 1257615 - can not import OpenSSL
can not import OpenSSL
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: python-cffi (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Eric Smith
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 09:04 EDT by Arindam Choudhury
Modified: 2018-04-11 07:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 15:17:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arindam Choudhury 2015-08-27 09:04:31 EDT
Description of problem:

I get a import error when i try to import OpenSSL.
ImportError: No module named pycparser

Version-Release number of selected component (if applicable):
pyOpenSSL-0.15.1-1.fc22.noarch

How reproducible:
always


Steps to Reproduce:
1. import OpenSSL

Actual results:

In [1]: import OpenSSL
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-1-df1d0c814255> in <module>()
----> 1 import OpenSSL

/usr/lib/python2.7/site-packages/OpenSSL/__init__.py in <module>()
      6 """
      7 
----> 8 from OpenSSL import rand, crypto, SSL
      9 from OpenSSL.version import __version__
     10 

/usr/lib/python2.7/site-packages/OpenSSL/rand.py in <module>()
      9 from six import integer_types as _integer_types
     10 
---> 11 from OpenSSL._util import (
     12     ffi as _ffi,
     13     lib as _lib,

/usr/lib/python2.7/site-packages/OpenSSL/_util.py in <module>()
      4 from six import PY3, binary_type, text_type
      5 
----> 6 from cryptography.hazmat.bindings.openssl.binding import Binding
      7 binding = Binding()
      8 ffi = binding.ffi

/usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/binding.py in <module>()
     58 
     59 
---> 60 class Binding(object):
     61     """
     62     OpenSSL API wrapper.

/usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/openssl/binding.py in Binding()
    107         pre_include=_OSX_PRE_INCLUDE,
    108         post_include=_OSX_POST_INCLUDE,
--> 109         libraries=_get_libraries(sys.platform)
    110     )
    111     lib = None

/usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/utils.pyc in build_ffi_for_binding(module_prefix, modules, pre_include, post_include, libraries, extra_compile_args, extra_link_args)
     95         libraries=libraries,
     96         extra_compile_args=extra_compile_args,
---> 97         extra_link_args=extra_link_args,
     98     )
     99 

/usr/lib64/python2.7/site-packages/cryptography/hazmat/bindings/utils.pyc in build_ffi(cdef_source, verify_source, libraries, extra_compile_args, extra_link_args)
    103 def build_ffi(cdef_source, verify_source, libraries=[], extra_compile_args=[],
    104               extra_link_args=[]):
--> 105     ffi = FFI()
    106     ffi.cdef(cdef_source)
    107 

/usr/lib64/python2.7/site-packages/cffi/api.pyc in __init__(self, backend)
     50         select a non-default backend, mostly for tests.
     51         """
---> 52         from . import cparser, model
     53         if backend is None:
     54             # You need PyPy (>= 2.0 beta), or a CPython (>= 2.6) with

/usr/lib64/python2.7/site-packages/cffi/cparser.py in <module>()
      4     from . import _pycparser as pycparser
      5 except ImportError:
----> 6     import pycparser
      7 import weakref, re, sys
      8 

ImportError: No module named pycparser


Expected results:


Additional info:

# pip list
asyncio (3.4.3)
Babel (1.3)
backports.ssl-match-hostname (3.4.0.2)
beautifulsoup4 (4.4.0)
binvox-rw (0.1)
blivet (1.0.10)
bzr (2.6.0)
cffi (1.2.1)
characteristic (14.3.0)
chardet (2.2.1)
configobj (5.0.5)
coverage (4.0b1)
cryptography (0.9)
cssselect (0.9.1)
datastream (0.4.9)
decorator (4.0.2)
DecoratorTools (1.8)
distribute (0.7.3)
docker-py (1.3.1)
ecdsa (0.11)
enum34 (1.0.4)
fedup (0.9.2)
funcsigs (0.4)
google-api-python-client (1.4.1)
httplib2 (0.9.1)
humanize (0.5.1)
idna (2.0)
iniparse (0.4)
ipaddress (1.0.14)
IPy (0.83)
ipython (4.0.0)
ipython-genutils (0.1.0)
jdcal (1.0)
jsonpointer (1.9)
jsonschema (2.4.0)
jusText (2.1.1)
kitchen (1.2.1)
langdetect (1.0.5)
langtable (0.0.34)
lxml (3.3.6)
Magic-file-extensions (0.2)
MarkupSafe (0.23)
matplotlib (1.4.3)
meld3 (1.0.2)
mock (1.3.0)
mongoengine (0.10.0)
ndg-httpsclient (0.3.2)
nose (1.3.7)
ntplib (0.3.3)
numpy (1.9.2)
oauth2client (1.4.12)
openpyxl (2.2.5)
packaging (15.3)
paramiko (1.15.2)
parse (1.6.6)
path.py (7.6)
pbr (1.5.0)
pexpect (3.3)
pickleshare (0.5)
Pillow (2.8.2)
pip (7.1.2)
ply (3.4)
policycoreutils-default-encoding (0.1)
progress (1.2)
psutil (3.1.1)
pwquality (1.2.4)
py (1.4.30)
pyasn1 (0.1.8)
pyasn1-modules (0.0.5)
pycparser (2.14)
pycrypto (2.6.1)
pycurl (7.19.5.1)
pydbus (0.2)
PyGithub (1.25.2)
Pygments (2.0.2)
pygobject (3.16.2)
pygpgme (0.3)
pyinotify (0.9.6)
PyIscsi (1.0)
pykickstart (1.99.66)
pyliblzma (0.5.3)
pymemcache (1.3.2)
pymongo (3.0.3)
pyOpenSSL (0.15.1)
pyparsing (2.0.3)
pyparted (3.10.4)
Warning: cannot find svn location for PyProtocols===1.0a0dev-r2302
PyProtocols (1.0a0dev-r2302)
pyserial (2.7)
pytest (2.7.2)
python-augeas (0.5.0)
python-dateutil (2.4.2)
python-dmidecode (3.10.13)
python-meh (0.40)
python-nss (0.16.0)
pytz (2015.4)
pyudev (0.16.1)
pyxattr (0.5.3)
PyXB (1.2.4)
pyxdg (0.25)
PyYAML (3.11)
pyzmq (14.4.1)
requests (2.7.0)
rpm-python (4.12.0.1)
rsa (3.2)
scripttest (1.3)
seobject (0.1)
sepolicy (1.1)
service-identity (14.0.0)
setroubleshoot (1.1)
setuptools (18.2)
sh (1.11)
shell (1.0.1)
shell.py (0.5.3)
simplegeneric (0.8.1)
simplejson (3.5.3)
six (1.9.0)
slip (0.6.1)
slip.dbus (0.6.1)
SSSDConfig (1.13.0)
supervisor (3.1.3)
tldextract (1.6)
tornado (3.2.2)
traitlets (4.0.0)
Twisted (15.3.0)
uritemplate (0.6)
urlgrabber (3.10.1)
urllib3 (1.11)
virtualenv (13.1.0)
websocket-client (0.32.0)
wheel (0.24.0)
yum-langpacks (0.4.5)
yum-metadata-parser (1.1.4)
zope.event (4.0.3)
zope.interface (4.1.2)
Comment 1 Fedora End Of Life 2016-07-19 15:17:25 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.