Bug 1257646 - [abrt] libreoffice-core: ytiled_to_linear(): soffice.bin killed by SIGSEGV
[abrt] libreoffice-core: ytiled_to_linear(): soffice.bin killed by SIGSEGV
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:aea63990dd1f996539325870560...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 10:08 EDT by simonandre
Modified: 2015-08-27 15:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 15:19:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (84.10 KB, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: core_backtrace (26.31 KB, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: dso_list (24.75 KB, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: environ (2.04 KB, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: maps (135.07 KB, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: mountinfo (3.31 KB, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: open_fds (2.92 KB, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: proc_pid_status (1015 bytes, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details
File: var_log_messages (274 bytes, text/plain)
2015-08-27 10:08 EDT, simonandre
no flags Details

  None (edit)
Description simonandre 2015-08-27 10:08:14 EDT
Description of problem:
1. start libreoffice write with new document

2. typing some text

3. ctrl +a -> to select all

4. text is selected with blue color, but the current stop refresh and we can't edit more  

Version-Release number of selected component:
libreoffice-core-4.4.5.2-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=5
crash_function: ytiled_to_linear
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     6430
kernel:         4.1.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 ytiled_to_linear at intel_tiled_memcpy.c:366
 #1 ytiled_to_linear_faster at intel_tiled_memcpy.c:521
 #2 tiled_to_linear at intel_tiled_memcpy.c:715
 #3 intel_readpixels_tiled_memcpy at intel_pixel_read.c:199
 #4 intelReadPixels at intel_pixel_read.c:257
 #5 _mesa_ReadnPixelsARB at main/readpix.c:1089
 #6 _mesa_ReadPixels at main/readpix.c:1097
 #7 OpenGLTexture::Read at /usr/src/debug/libreoffice-4.4.5.2/vcl/opengl/texture.cxx:320
 #8 OpenGLSalBitmap::ReadTexture at /usr/src/debug/libreoffice-4.4.5.2/vcl/opengl/salbmp.cxx:451
 #9 OpenGLSalBitmap::AcquireBuffer at /usr/src/debug/libreoffice-4.4.5.2/vcl/opengl/salbmp.cxx:491
Comment 1 simonandre 2015-08-27 10:08:18 EDT
Created attachment 1067762 [details]
File: backtrace
Comment 2 simonandre 2015-08-27 10:08:20 EDT
Created attachment 1067763 [details]
File: cgroup
Comment 3 simonandre 2015-08-27 10:08:21 EDT
Created attachment 1067764 [details]
File: core_backtrace
Comment 4 simonandre 2015-08-27 10:08:23 EDT
Created attachment 1067765 [details]
File: dso_list
Comment 5 simonandre 2015-08-27 10:08:24 EDT
Created attachment 1067766 [details]
File: environ
Comment 6 simonandre 2015-08-27 10:08:25 EDT
Created attachment 1067767 [details]
File: limits
Comment 7 simonandre 2015-08-27 10:08:28 EDT
Created attachment 1067768 [details]
File: maps
Comment 8 simonandre 2015-08-27 10:08:30 EDT
Created attachment 1067769 [details]
File: mountinfo
Comment 9 simonandre 2015-08-27 10:08:31 EDT
Created attachment 1067770 [details]
File: namespaces
Comment 10 simonandre 2015-08-27 10:08:32 EDT
Created attachment 1067771 [details]
File: open_fds
Comment 11 simonandre 2015-08-27 10:08:34 EDT
Created attachment 1067772 [details]
File: proc_pid_status
Comment 12 simonandre 2015-08-27 10:08:35 EDT
Created attachment 1067773 [details]
File: var_log_messages
Comment 13 simonandre 2015-08-27 10:15:51 EDT
Sorry, it's an rendering issue when you activate opengl for all rendering.
Comment 14 Michael Stahl 2015-08-27 15:19:39 EDT
you mean the "Use OpenGL for all rendering" setting?

OpenGL in LO 4.4 is highly experimental and i don't think we'll investigate any problems there.  try it in 5.0, hopefully it should work a little better.

Note You need to log in before you can comment on or make changes to this bug.