Bug 1257736 - \S or \S{VARIABLE} doesn't work as described in man page when we login via telnet
\S or \S{VARIABLE} doesn't work as described in man page when we login via te...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: telnet (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Luboš Uhliarik
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 15:36 EDT by Yoshifumi Kinoshita
Modified: 2016-03-17 10:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 10:47:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Karel Zak 2016-01-13 07:02:40 EST
/etc/issue and /etc/issue.net are completely independent files and agetty is really not used for telnet sessions.
Comment 4 Jay Rishel 2016-03-16 15:28:12 EDT
this looks like a bug in agetty, it is supposed to parse the contents of /etc/issue and replace the "/S" line with the sting "Red Hat Enterprise Linux Server release 7.2 (Maipo)" which is supposed to be parsed out of /etc/os-release's "PRETTY_NAME" entry, but it is not.  it is outputting "/S" which is not the behavior described in the agetty man page. 

I see this on RHEL 7.2 when connecting via ssh, so not a telnet issue, but an agetty issue.
Comment 5 Luboš Uhliarik 2016-03-17 10:47:12 EDT
I looked a little bit more info source file, and I found, that %S or \S macro is not supported by telnetd. 


FROM MAN PAGE:
~~~~~~~~~~~~~

NAME
     issue.net — identification file for telnet sessions

DESCRIPTION
     The file /etc/issue.net is a text file which contains a message or system identification to be printed before the login prompt of a telnet session. It may contain
     various `%-char' (or, alternatively, '\-char') sequences. The following sequences are supported by telnetd:
           %l     - show the current tty
           %h, %n
                  - show the system node name (FQDN)
           %D, %o
                  - show the name of the NIS domain
           %d, %t
                  - show the current time and date
           %s     - show the name of the operating system
           %m     - show the machine (hardware) type
           %r     - show the operating system release
           %v     - show the operating system version
           %%     - display a single '%' character

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Therefore, this is not a bug and I'm closing it as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.