Bug 1257756 - Utilization button disabled for RHEV VMs when C&U collection is happening
Utilization button disabled for RHEV VMs when C&U collection is happening
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.0
Assigned To: Dan Clarizio
Dave Johnson
: ZStream
Depends On:
Blocks: 1262012
  Show dependency treegraph
 
Reported: 2015-08-27 17:38 EDT by Nandini Chandra
Modified: 2015-11-11 15:32 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1262012 (view as bug list)
Environment:
Last Closed: 2015-09-11 18:42:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2015-08-27 17:38:31 EDT
Description of problem:
-----------------------
The Utilization button is disabled for RHEV VMs when C&U collection is happening.The Utilization button is not greyed out for the VM's host or the  cluster.I see this happening on just one of my appliances.

My appliance is also managing a vsphere provider,but I don't see this issue on vsphere.

Version-Release number of selected component (if applicable):
---------------------
5.4.2


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Enable C&U collection for a RHEV provider


Actual results:
---------------
Utilization button is disabled for RHEV VMs even when C&U data collection is happening.


Expected results:
----------------
Utilization button should be enabled for RHEV VMs when C&U data collection is happening.


Additional info:
----------------
DB shows realtime C&U data being captured for these RHEV VMs.
Comment 1 Nandini Chandra 2015-08-27 17:42:01 EDT
I see these error messages in evm.log,but it looks like this error is being logged for archived VMs.

evm.log:[----] E, [2015-08-27T04:06:44.944687 #10083:b9dea8] ERROR -- : MIQ(VmRedhat.perf_collect_metrics) [realtime] for: [VmRedhat], [2086], [test_pwrctl_GjznzyGHhq]   Timings at time of error: {:capture_state=>23.015830516815186, :rhevm_connect=>0.0002491474151611328}
evm.log:[----] E, [2015-08-27T04:06:44.944963 #10083:b9dea8] ERROR -- : [NoMethodError]: undefined method `has_authentication_type?' for nil:NilClass  Method:[rescue in perf_collect_metrics_rhevm
Comment 6 Nandini Chandra 2015-09-11 18:42:21 EDT
It looks like the appliance on which the issue was seen doesn't exist any more.I will reopen the bug if the issue occurs again.

Note You need to log in before you can comment on or make changes to this bug.