Bug 1257771 - Getting "Build error: exit status 128 from git clone timeout" during the S2I build
Getting "Build error: exit status 128 from git clone timeout" during the S2I ...
Status: CLOSED WORKSFORME
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking (Show other bugs)
3.0.0
Unspecified Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Bennett
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 20:37 EDT by Kenjiro Nakayama
Modified: 2015-10-14 23:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 16:02:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Origin (Github) 3820 None None None Never

  None (edit)
Description Kenjiro Nakayama 2015-08-27 20:37:25 EDT
Issue:
---
- During S2I build(source strategy), we hit the error "Build error: exit status 128 from git clone timeout" and build failed.
- The issue looks like same with the issue which reported to the upstream[1]. But in this time, the environment was OSE v3.0.1.0.(Please see Env section)

[1] https://github.com/openshift/origin/issues/3820


Env:
---
$ openshift version
openshift v3.0.1.0-528-g8c2fe51
kubernetes v1.0.0

$ docker version
Client version: 1.7.1
Client API version: 1.19
Package Version (client): docker-1.7.1-108.el7.x86_64
Go version (client): go1.4.2
Git commit (client): 3043001/1.7.1
OS/Arch (client): linux/amd64
Server version: 1.7.1
Server API version: 1.19
Package Version (server): docker-1.7.1-108.el7.x86_64
Go version (server): go1.4.2
Git commit (server): 3043001/1.7.1
OS/Arch (server): linux/amd64

# docker images |grep openshift (on master node)
registry.access.redhat.com/openshift3/ruby-20-rhel7     latest              fcba2071846c        3 weeks ago         391.6 MB
registry.access.redhat.com/openshift3/ose-pod           v3.0.1.0            780de0beef81        3 weeks ago         233.7 MB
registry.access.redhat.com/openshift3/ose-sti-builder   v3.0.1.0            9a8b15996843        3 weeks ago         287.6 MB

*NOTE*
- No proxy used in this environment.
- The environment is OSE on AWS.


Steps to Reproduce:
---
1. Start new build with oc new-app.
2. Check build-logs


Error:
---
I0823 08:57:00.218725       1 docker.go:199] Image registry.access.redhat.com/openshift3/ruby-20-rhel7:latest available locally
I0823 08:57:00.218796       1 sti.go:93] Creating a new S2I builder with build config: "Builder Name:\t\tRuby 2.0\nBuilder Image:\t\tregistry.access.redhat.com/openshift3/ruby-20-rhel7:latest\nSource:\t\t\thttps://github.com/waynedovey/ruby-hello-world\nOutput Image Tag:\t172.xxx.xxx.xxx:5000/lifecycle/ruby-hello-world:latest\nEnvironment:\t\tOPENSHIFT_BUILD_NAMESPACE=lifecycle,OPENSHIFT_BUILD_SOURCE=https://github.com/waynedovey/ruby-hello-world,OPENSHIFT_BUILD_NAME=ruby-hello-world-9\nIncremental Build:\tdisabled\nRemove Old Build:\tdisabled\nForce Pull:\t\tdisabled\nQuiet:\t\t\tdisabled\nLayered Build:\t\tdisabled\nDocker Endpoint:\tunix:///var/run/docker.sock\n"
I0823 08:57:00.220849       1 docker.go:199] Image registry.access.redhat.com/openshift3/ruby-20-rhel7:latest available locally
I0823 08:57:00.222963       1 sti.go:99] Starting S2I build from lifecycle/ruby-hello-world-9 BuildConfig ...
I0823 08:57:00.222979       1 sti.go:113] Building 172.xxx.xxx.xxx:5000/lifecycle/ruby-hello-world:latest
I0823 08:57:00.238957       1 clone.go:27] Cloning into /tmp/sti487742716/upload/src
I0823 08:57:00.203832       1 builder.go:42] $BUILD env var is {"kind":"Build","apiVersion":"v1","metadata":{"name":"ruby-hello-world-9","namespace":"lifecycle","selfLink":"/oapi/v1/namespaces/lifecycle/builds/ruby-hello-world-9","uid":"6f906f3f-4996-11e5-bc20-0206c89012f5","resourceVersion":"4932","creationTimestamp":"2015-08-23T12:56:57Z","labels":{"app":"ruby-hello-world","buildconfig":"ruby-hello-world"}},"spec":{"serviceAccount":"builder","source":{"type":"Git","git":{"uri":"https://github.com/waynedovey/ruby-hello-world"}},"strategy":{"type":"Source","sourceStrategy":{"from":{"kind":"DockerImage","name":"registry.access.redhat.com/openshift3/ruby-20-rhel7:latest"}}},"output":{"to":{"kind":"DockerImage","name":"172.xxx.xxx.xxx:5000/lifecycle/ruby-hello-world:latest"},"pushSecret":{"name":"builder-dockercfg-ncq5g"}},"resources":{}},"status":{"phase":"Pending","config":{"kind":"BuildConfig","namespace":"lifecycle","name":"ruby-hello-world"}}}
I0823 08:57:00.215905       1 cfg.go:50] Problem accessing /root/.dockercfg: stat /root/.dockercfg: no such file or directory
I0823 08:57:00.218725       1 docker.go:199] Image registry.access.redhat.com/openshift3/ruby-20-rhel7:latest available locally
I0823 08:57:00.218796       1 sti.go:93] Creating a new S2I builder with build config: "Builder Name:\t\tRuby 2.0\nBuilder Image:\t\tregistry.access.redhat.com/openshift3/ruby-20-rhel7:latest\nSource:\t\t\thttps://github.com/waynedovey/ruby-hello-world\nOutput Image Tag:\t172.xxx.xxx.xxx:5000/lifecycle/ruby-hello-world:latest\nEnvironment:\t\tOPENSHIFT_BUILD_NAMESPACE=lifecycle,OPENSHIFT_BUILD_SOURCE=https://github.com/waynedovey/ruby-hello-world,OPENSHIFT_BUILD_NAME=ruby-hello-world-9\nIncremental Build:\tdisabled\nRemove Old Build:\tdisabled\nForce Pull:\t\tdisabled\nQuiet:\t\t\tdisabled\nLayered Build:\t\tdisabled\nDocker Endpoint:\tunix:///var/run/docker.sock\n"
I0823 08:57:00.220849       1 docker.go:199] Image registry.access.redhat.com/openshift3/ruby-20-rhel7:latest available locally
I0823 08:57:00.222963       1 sti.go:99] Starting S2I build from lifecycle/ruby-hello-world-9 BuildConfig ...
I0823 08:57:00.222979       1 sti.go:113] Building 172.xxx.xxx.xxx:5000/lifecycle/ruby-hello-world:latest
I0823 08:57:00.238957       1 clone.go:27] Cloning into /tmp/sti487742716/upload/src
E0823 08:59:07.653475       1 git.go:127] fatal: unable to access 'https://github.com/waynedovey/ruby-hello-world/': Failed connect to github.com:443; Connection timed out
I0823 08:59:07.656487       1 clone.go:29] Git clone failed: exit status 128
I0823 08:59:07.656522       1 cleanup.go:23] Removing temporary directory /tmp/sti487742716
I0823 08:59:07.656528       1 fs.go:99] Removing directory '/tmp/sti487742716'
F0823 08:59:07.658951       1 builder.go:65] Build error: exit status 128
Comment 2 Cesar Wong 2015-08-28 14:14:46 EDT
This looks like an issue with the SDN, the builder pod can't access the external network.
Comment 3 Ben Bennett 2015-09-11 09:01:52 EDT
Can you either give me access to the system... or mail me the output from:

* oc get endpoints
* Then run through the list of endpoints and ping them
* ovs-ofctl -O OpenFlow13 dump-flows br0  [br0 may not be the right interface]

Thanks
Comment 4 Kenjiro Nakayama 2015-09-11 09:12:43 EDT
(In reply to Ben Bennett from comment #3)

As far as I know, the client who hit this error downgraded to v3.0.0.1 and the error disappeared. (I tried to confirm it, but no reply yet.)

http://post-office.corp.redhat.com/archives/openshift-sme/2015-August/msg01214.html (internal)

Thus, we don't have any reproducible environment now except for the @grdryn's on https://github.com/openshift/origin/issues/3820
Comment 5 Ben Bennett 2015-09-22 16:02:32 EDT
Unfortunately, I can't reproduce this.  The other issue of @grdryn's that you reference has a proposed solution which he hasn't responded to yet.  But we can track that there.

Please re-open this if you reproduce it, or can get me access to a broken system.  Thanks.
Comment 6 Kenjiro Nakayama 2015-09-24 00:40:21 EDT
Thank you Ben. I agree. If we can reproduce it or any activity, I will re-open this BZ and let you know.
Comment 7 Kenjiro Nakayama 2015-10-14 23:32:15 EDT
Just FYI, the cause of this issue was DNS setting. I wrote the KCS here - https://access.redhat.com/solutions/1990683

We can completely close this ticket.

Note You need to log in before you can comment on or make changes to this bug.