Bug 1257827 - Internal system error popped up, reporting as requested.
Internal system error popped up, reporting as requested.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.7
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 03:43 EDT by Kjell Arne
Modified: 2015-11-23 07:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 07:30:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjell Arne 2015-08-28 03:43:26 EDT
Error Type: <class 'up2date_client.up2dateErrors.NetworkError'>
Error Value: rhn-plugin: Network error: Connection reset by peer
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3282, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3279, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 702, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 609, in dispatch_command
    self.refresh_cache(force)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1562, in refresh_cache
    self._check_init()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2839, in _check_init
    repo.repoXML
  File : /usr/lib/python2.6/site-packages/yum/yumRepo.py, line 1459, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File : /usr/share/yum-plugins/rhnplugin.py, line 562, in _getRepoXML
    return YumRepository._getRepoXML(self)
  File : /usr/lib/python2.6/site-packages/yum/yumRepo.py, line 1451, in _getRepoXML
    self._loadRepoXML(text=self)
  File : /usr/lib/python2.6/site-packages/yum/yumRepo.py, line 1441, in _loadRepoXML
    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
  File : /usr/lib/python2.6/site-packages/yum/yumRepo.py, line 1416, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File : /usr/lib/python2.6/site-packages/yum/yumRepo.py, line 1234, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File : /usr/lib/python2.6/site-packages/yum/yumRepo.py, line 1012, in _getFileRepoXML
    size=102400) # setting max size as 100K
  File : /usr/share/yum-plugins/rhnplugin.py, line 387, in _getFile
    up2dateAuth.updateLoginInfo(timeout=self.timeout)
  File : /usr/share/rhn/up2date_client/up2dateAuth.py, line 204, in updateLoginInfo
    login(forceUpdate=True, timeout=timeout)
  File : /usr/share/rhn/up2date_client/up2dateAuth.py, line 186, in login
    li = server.up2date.login(systemId)
  File : /usr/share/rhn/up2date_client/rhnserver.py, line 51, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File : /usr/share/rhn/up2date_client/rpcServer.py, line 210, in doCall
    ret = method(*args, **kwargs)
  File : /usr/lib64/python2.6/xmlrpclib.py, line 1199, in __call__
    return self.__send(self.__name, args)
  File : /usr/share/rhn/up2date_client/rpcServer.py, line 40, in _request1
    ret = self._request(methodname, params)
  File : /usr/lib/python2.6/site-packages/rhn/rpclib.py, line 386, in _request
    self._handler, request, verbose=self._verbose)
  File : /usr/lib/python2.6/site-packages/rhn/transports.py, line 171, in request
    headers, fd = req.send_http(host, handler)
  File : /usr/lib/python2.6/site-packages/rhn/transports.py, line 725, in send_http
    response = self._connection.getresponse()
  File : /usr/lib/python2.6/site-packages/rhn/connections.py, line 130, in getresponse
    response.begin()
  File : /usr/lib64/python2.6/httplib.py, line 404, in begin
    version, status, reason = self._read_status()
  File : /usr/lib64/python2.6/httplib.py, line 360, in _read_status
    line = self.fp.readline(_MAXLINE + 1)
  File : /usr/lib/python2.6/site-packages/rhn/SSL.py, line 265, in readline
    data = self._connection.recv(bufsize)
Comment 2 Tomas Lestach 2015-08-28 03:57:24 EDT
Hello Kjell,
would you, please, contact Red Hat support to help you with this issue?
Comment 3 Tomáš Kašpárek 2015-11-23 05:42:45 EST
Looks like networking issue to me....
Comment 4 Kjell Arne 2015-11-23 07:21:15 EST
It might very well be. It only happened the one time, so I don't know much of what caused it. 
The only reason I reported it was because the dialogue asked me to. I wouldn't mind closing it if you have a probable cause.
Comment 5 Tomáš Kašpárek 2015-11-23 07:30:17 EST
As per comment#4, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.