Bug 1257835 - RHEV Agent service will consume almost 100% cpu on win2012R2 and win8-32 OS
RHEV Agent service will consume almost 100% cpu on win2012R2 and win8-32 OS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.5.0
Unspecified Unspecified
high Severity high
: ovirt-4.0.0-alpha
: ---
Assigned To: Vinzenz Feenstra [evilissimo]
Jiri Belka
: Reopened, ZStream
Depends On:
Blocks: 1328398
  Show dependency treegraph
 
Reported: 2015-08-28 04:25 EDT by Min Deng
Modified: 2017-06-22 07:32 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously when the RHEVM Guest Agent was running and had some IO errors on reading from or writing to the VirtIO Socket errors would lead to a non ratelimited endless loop until the error would resolve itself. This had a very bad performance impact on the Virtual Machine. This has been resolved.
Story Points: ---
Clone Of:
: 1328398 (view as bug list)
Environment:
Last Closed: 2016-08-29 07:51:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (160.25 KB, image/png)
2015-08-28 04:26 EDT, Min Deng
no flags Details
Logs (3.82 MB, application/zip)
2015-09-18 03:14 EDT, Min Deng
no flags Details
LOG (525 bytes, text/plain)
2015-09-22 23:23 EDT, Min Deng
no flags Details
Tool to check the presence of the Agent Channel (54.39 KB, application/zip)
2015-09-24 08:08 EDT, Vinzenz Feenstra [evilissimo]
no flags Details
Install logs (454.97 KB, application/zip)
2015-12-17 03:52 EST, Alexandros Gkesos
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53909 master MERGED windows: More defensive code for windows VirtIO handling 2016-03-14 05:21 EDT
oVirt gerrit 54710 ovirt-3.6 MERGED windows: More defensive code for windows VirtIO handling 2016-03-14 05:23 EDT

  None (edit)
Comment 1 Min Deng 2015-08-28 04:26:37 EDT
Created attachment 1067926 [details]
screenshot
Comment 6 Min Deng 2015-09-18 03:14:45 EDT
Created attachment 1074695 [details]
Logs

Collected some logs from my guest and please have a look,any issues please let me know,thanks.

Min
Comment 7 Vinzenz Feenstra [evilissimo] 2015-09-22 04:52:07 EDT
Please attach the following file: 

C:\Program Files (x86)\Redhat\RHEV\Tools\InstallLogs\Install.rhev-agent-service.log

Thanks.
Comment 8 Min Deng 2015-09-22 23:23 EDT
Created attachment 1076074 [details]
LOG
Comment 9 Vinzenz Feenstra [evilissimo] 2015-09-24 08:08 EDT
Created attachment 1076487 [details]
Tool to check the presence of the Agent Channel
Comment 10 Vinzenz Feenstra [evilissimo] 2015-09-24 08:10:01 EDT
Please run the above tool as administrator from cmd.exe

And paste the output. Thank you.
Comment 19 Vinzenz Feenstra [evilissimo] 2015-11-11 10:48:33 EST
After digging around more and re-reading the above used qemu commandline, I found out that this has not been used with RHEVM and not started how this is used by us.

This is an example how this is used, and this works for me just fine. 

-chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/b45a81a9-ce10-4cd3-acb7-bfe2f6344302.com.redhat.rhevm.vdsm,server,nowait
-device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm

Any other mechanism than a local unix domain socket on the server side is at this point not supported nor tested
Comment 20 Michal Skrivanek 2015-11-12 02:46:54 EST
please make sure to open the bug against the right product, if you're not using RHEV you need to note it in the bug
Comment 28 Alexandros Gkesos 2015-12-17 03:52 EST
Created attachment 1106619 [details]
Install logs
Comment 41 Michal Skrivanek 2016-02-10 07:49:29 EST
Vinzenz, can we do some defensive code based on the hunch in comment #33?
Comment 42 Vinzenz Feenstra [evilissimo] 2016-02-23 08:39:53 EST
Posted a patch with defensive code, to slow down on communication errors - Also adding debug logs in that case to be able to get some information when switched to DEBUG.
Comment 45 Vinzenz Feenstra [evilissimo] 2016-05-16 03:42:26 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=1328398
Comment 47 Jiri Belka 2016-05-31 07:40:28 EDT
ok, RHEV-toolsSetup_4.0_1.iso

logged IO errors about virtio channel in DEBUG level

Note You need to log in before you can comment on or make changes to this bug.