Bug 1257921 - [aaajdbc] Please be consistent in naming of internal-authz
[aaajdbc] Please be consistent in naming of internal-authz
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Perina
Ondra Machacek
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 08:12 EDT by Ondra Machacek
Modified: 2016-02-10 14:14 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-28 08:35:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2015-08-28 08:12:12 EDT
Description of problem:

If you upgrade engine from 3.5 to 3.6 you will have internal domain as follows:
authz-name : internal
authn-name : internal-authn
profile-name : internal

It would be nice if there will be this approach also in clean 3.6 install,
as currently it is as follows:
authz-name : internal-authz
authn-name : internal-authn
profile-name : internal
Comment 1 Martin Perina 2015-08-28 08:35:28 EDT
(In reply to Ondra Machacek from comment #0)
> Description of problem:
> 
> If you upgrade engine from 3.5 to 3.6 you will have internal domain as
> follows:
> authz-name : internal
> authn-name : internal-authn
> profile-name : internal

This is legacy naming scheme, which was caused by conversion of legacy internal AAA code into extension. And we decided not to change it to the new naming scheme during upgrade.

> 
> It would be nice if there will be this approach also in clean 3.6 install,
> as currently it is as follows:
> authz-name : internal-authz
> authn-name : internal-authn
> profile-name : internal

This is the new standard naming scheme for aaa extensions, extensions should be named as PROFILE-EXTNAME and all extensions should use this scheme.
Comment 2 Alon Bar-Lev 2015-08-29 12:38:13 EDT
(In reply to Martin Perina from comment #1)
> (In reply to Ondra Machacek from comment #0)
> > Description of problem:
> > 
> > If you upgrade engine from 3.5 to 3.6 you will have internal domain as
> > follows:
> > authz-name : internal
> > authn-name : internal-authn
> > profile-name : internal
> 
> This is legacy naming scheme, which was caused by conversion of legacy
> internal AAA code into extension. And we decided not to change it to the new
> naming scheme during upgrade.
> 

then authn name is important as user resides within, during upgrade we must keep it so existing admin keep working.

Note You need to log in before you can comment on or make changes to this bug.