Bug 125797 - authconfig's accelerator keys are useless
authconfig's accelerator keys are useless
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: authconfig (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-11 11:40 EDT by Chris Lee
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 13:00:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
to test it, copy it to /usr/share/authconfig/ (108.65 KB, text/plain)
2004-08-25 09:24 EDT, Jindrich Novy
no flags Details

  None (edit)
Description Chris Lee 2004-06-11 11:40:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.4

Description of problem:
Authconfig-GTK's keyboard accelerators are practically unusable; all
of the "Configure [module]" buttons have the 'C' key set as their
accelerator, as does the 'Cache User Information' checkbox, as well as
the 'Cancel' button.

This means that there are six widgets sharing the same keyboard
accelerator, which defeats the whole point of having an accelerator
key in the first place.

Version-Release number of selected component (if applicable):
authconfig-gtk-4.6.3-1

How reproducible:
Always

Steps to Reproduce:
1. Open authconfig-gtk
2. Hold down the Alt key and hit 'C'
3. Endless hours of amusement as the focus switches every time you hit
the C key

Expected Results:  Only one widget should have 'C' set as its
accelerator, so when I hit alt+C, it will activate that widget instead
of playing Musical Widget Focus on me.

Actual Results:  The application focuses on a different widget every
time I hit Alt+C instead of activating the one that I intended it to.
Comment 1 Jindrich Novy 2004-08-25 09:19:41 EDT
Hi Chris,

I modified the authconfig-gtk interface to two-column design and fixed
the keyboard accelerators conflicts. Attaching authconfig.glade so you
can test it. Please let me know what do you say to the new accelerators.

greetings,
Jindrich
Comment 2 Jindrich Novy 2004-08-25 09:24:04 EDT
Created attachment 103069 [details]
to test it, copy it to /usr/share/authconfig/
Comment 3 Chris Lee 2004-09-24 15:51:31 EDT
Jindrich, thanks for your test file! This fixes a few of my concerns
with the UI. However, I still think that this interface is pretty
broken... the 'Configure' buttons on each page still all share the
same accelerator.

I'm going to see if I can whip up an example of a UI that I think
would solve most of the issues with the current authconfig-gtk UI. As
for this particular bug, if you wanted to commit your version I would
say that the uselessness of the keyboard accelerators is at least
somewhat fixed by your version.

There are still other bugs with the interface (too large for small
screens, too much information by default, *some* of the keyboard
accelerators are still shared...), but at least this is a step in the
right direction.
Comment 4 Tomas Mraz 2004-12-13 13:00:22 EST
The shared accelerators problem is fixed in FC3/RHEL4 release. For
other improvements of the UI, please open new bugs. (With proposals
how to change it if possible.)

Note You need to log in before you can comment on or make changes to this bug.