Bug 1257991 - SO Version number change
SO Version number change
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 10:45 EDT by Edward Rudd
Modified: 2015-08-31 05:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 05:37:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Rudd 2015-08-28 10:45:41 EDT
Description of problem:
openssl in Fedora / RHEL / CentOS product lines use an altered SO version number of 10 instead of the stock package version number of 1.0.0.  This causes binaries build against Fedora / RHEL / CentOS that use OpenSSL to not work on every other linux distribution out there.

Version-Release number of selected component (if applicable):
Any 1.x version in the Fedora/RHEL based products

How reproducible:
100%

Additional info:

As I build binary-only commercial games and game ports for linux. I use CentOS as my build system base.  However OpenSSL is consistently a thorn in my side due to this mismatch of SONAMEs and I have to resort to building a dynamic loader into the games (to dlopen the OpenSSL on the user's system).

It would make things much more portable if every distribution used the same SONAME for OpenSSL
Comment 1 Tomas Mraz 2015-08-31 05:37:27 EDT
Unfortunately we cannot change the SONAME for existing OpenSSL packages. And also note that our package is heavily patched which (for example the FIPS support) breaks the ABI compatibility with the upstream package.

When the upstream breaks the API/ABI again which is planned for a future release of OpenSSL, we could then decide to use the upstream SONAME. The decision will be based on whether the difference between the upstream package and our package that will be probably still heavily patched warrants the SONAME difference or not.

Note You need to log in before you can comment on or make changes to this bug.