Bug 125810 - Can't up2date an AS3.0 through Proxy to Local Satellite
Can't up2date an AS3.0 through Proxy to Local Satellite
Status: CLOSED DUPLICATE of bug 115385
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Todd Warner
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-11 14:16 EDT by greg pryzby
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description greg pryzby 2004-06-11 14:16:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
I register a AS 3.0 client via Proxy to our Internal Satellite. When I
apply errata on Satellite and run rhn_check on client, the first
errata is applied and the rest of the errata fails with a protocol
error. If I apply the errata again and run rhn_check, the first errata
is applied and the rest fail. I can step though all the errata this
way, but it is broken.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Build AS3.0 client
2. Register AS 3.0 with Satellite via Proxy
3. Apply errata for client via Satellite GUI
4. On client, run rhn_check
5. Output from /var/log/up2date on client

[Fri Jun 11 11:26:56 2004] up2date updating login info
[Fri Jun 11 11:26:56 2004] up2date logging into up2date server
[Fri Jun 11 11:26:56 2004] up2date successfully retrieved
authentication token from up2date server
[Fri Jun 11 11:26:56 2004] up2date availablePackageList from network
[Fri Jun 11 11:26:58 2004] up2date installing packages:
['SysVinit-2.85-4.2']
[Fri Jun 11 11:27:02 2004] up2date Removing packages from package
profile: ['SysVinit-2.85-4']
[Fri Jun 11 11:27:02 2004] up2date Adding packages to package profile:
['SysVinit-2.85-4.2']
[Fri Jun 11 11:27:03 2004] up2date deleting
/var/spool/up2date/SysVinit-2.85-4.2.i386.hdr
[Fri Jun 11 11:27:03 2004] up2date deleting
/var/spool/up2date/SysVinit-2.85-4.2.i386.rpm
[Fri Jun 11 11:27:03 2004] up2date updating login info
[Fri Jun 11 11:27:03 2004] up2date logging into up2date server
[Fri Jun 11 11:27:04 2004] up2date successfully retrieved
authentication token from up2date server
[Fri Jun 11 11:27:05 2004] up2date A protocol error occurred: Not
Found , attempt #1,
[Fri Jun 11 11:27:10 2004] up2date A protocol error occurred: Not
Found , attempt #2,
......

    

Expected Results:  All the errata should have been applied.

Additional info:
Comment 1 Todd Warner 2004-06-15 11:19:59 EDT
See bug 115385

Will deliver patch to customer ASAP (i.e., as soon as QA gives an OK
for beta).


*** This bug has been marked as a duplicate of 115385 ***
Comment 2 Todd Warner 2004-06-15 11:21:07 EDT
It's an up2date bug by the way... so changed the component to reflect
that.
Comment 3 Todd Warner 2004-06-17 12:19:52 EDT
Patch delivered to consultant.
Comment 4 Red Hat Bugzilla 2006-02-21 14:04:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.