Bug 1258115 - Do not use NM for br-ex/eth0 in overcloud images [NEEDINFO]
Do not use NM for br-ex/eth0 in overcloud images
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-image-elements (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 7.0 (Kilo)
Assigned To: James Slagle
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-29 06:14 EDT by Marko Myllynen
Modified: 2016-04-18 03:12 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 12:53:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
calfonso: needinfo? (agarciam)


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2015-08-29 06:14:05 EDT
Description of problem:
When deploying overcloud with three controllers and two computes we saw compute nodes occasionally becoming unreachable, adding NM_CONTROLLED=no to ifcfg-br-ex and ifcfg-eth0 solved the issue. Looks like this should be by default.
Comment 4 Dan Prince 2015-08-31 10:02:46 EDT
I believe this may be solved by this upstream revision:

http://git.openstack.org/cgit/openstack/os-net-config/commit/?id=afcd514b7cb4b9a465c615c0a16d7f6af2a1d0ed

Is this just something to backport and/or rebase to fix?
Comment 5 James Slagle 2015-08-31 10:07:32 EDT
can you check what version of os-net-config is installed on your overcloud nodes?

rpm -q os-net-config
Comment 6 Hugh Brock 2015-08-31 10:43:03 EDT
This should be in the current version of os-net-config, which is 0.1.4. It was fixed with this patch:

http://git.openstack.org/cgit/openstack/os-net-config/commit/?id=afcd514b7cb4b9a465c615c0a16d7f6af2a1d0ed

It is possible you are using out-of-date images, or non-updated ones. If not, then we need to investigate where this regression came from. Can you have a look at the package versions on your deployment image and the actual code and let us know what the situation is?

Thanks...
Comment 7 chris alfonso 2015-09-14 13:00:10 EDT
Waiting for your result on checking that you are using the latest

Note You need to log in before you can comment on or make changes to this bug.