This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1258126 - [abrt] abrt: augeas.py:75:_dlopen:ImportError: Unable to import libaugeas!
[abrt] abrt: augeas.py:75:_dlopen:ImportError: Unable to import libaugeas!
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:7cfc7a1873f1dff18aa9d0266cb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-29 07:54 EDT by Amol
Modified: 2015-08-31 06:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 06:14:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (654 bytes, text/plain)
2015-08-29 07:54 EDT, Amol
no flags Details
File: environ (321 bytes, text/plain)
2015-08-29 07:54 EDT, Amol
no flags Details
augeas import test (77 bytes, text/x-python)
2015-08-31 06:32 EDT, Matej Habrnal
no flags Details

  None (edit)
Description Amol 2015-08-29 07:54:30 EDT
Version-Release number of selected component:
abrt-2.6.1-2.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python -u /usr/libexec/abrt-action-ureport
dso_list:       python-augeas-0.5.0-2.fc22.noarch
executable:     /usr/libexec/abrt-action-ureport
kernel:         4.1.3-201.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
augeas.py:75:_dlopen:ImportError: Unable to import libaugeas!

Traceback (most recent call last):
  File "/usr/libexec/abrt-action-ureport", line 11, in <module>
    import augeas
  File "/usr/lib/python2.7/site-packages/augeas.py", line 78, in <module>
    class Augeas(object):
  File "/usr/lib/python2.7/site-packages/augeas.py", line 82, in Augeas
    _libaugeas = _dlopen("augeas")
  File "/usr/lib/python2.7/site-packages/augeas.py", line 75, in _dlopen
    raise ImportError("Unable to import lib%s!" % args[0])
ImportError: Unable to import libaugeas!

Local variables in innermost frame:
libs: []
a: 'augeas'
args: ('augeas',)
l: None
lib: None
Comment 1 Amol 2015-08-29 07:54:37 EDT
Created attachment 1068269 [details]
File: backtrace
Comment 2 Amol 2015-08-29 07:54:42 EDT
Created attachment 1068270 [details]
File: environ
Comment 3 Matej Habrnal 2015-08-31 06:14:36 EDT
Thank you for the bug report!

I cannot reproduce the bug witch simple script where I try to import augeas.

I close the bug as NOTABUG, but feel free to reopen it if the issue is still present in new updates.
Comment 4 Matej Habrnal 2015-08-31 06:32:06 EDT
Created attachment 1068589 [details]
augeas import test

Here is the python script "augeas_import_test.py" with which I tried to reproduce the bug.
Please run the script "$ ./augeas_import_test.py" and if the issue still occurs, please reopen the bugzulla.

Note You need to log in before you can comment on or make changes to this bug.