Bug 1258178 - [abrt] qt-creator: __libc_sigaction(): qtcreator killed by SIGABRT
[abrt] qt-creator: __libc_sigaction(): qtcreator killed by SIGABRT
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt-creator (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:fa61c1791399c428b91aa0d8d3a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-29 18:46 EDT by mmg
Modified: 2015-08-30 08:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-30 08:19:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (39.38 KB, text/plain)
2015-08-29 18:46 EDT, mmg
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-29 18:46 EDT, mmg
no flags Details
File: core_backtrace (6.71 KB, text/plain)
2015-08-29 18:46 EDT, mmg
no flags Details
File: dso_list (20.65 KB, text/plain)
2015-08-29 18:46 EDT, mmg
no flags Details
File: environ (1.56 KB, text/plain)
2015-08-29 18:46 EDT, mmg
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-29 18:46 EDT, mmg
no flags Details
File: maps (100.84 KB, text/plain)
2015-08-29 18:46 EDT, mmg
no flags Details
File: mountinfo (3.24 KB, text/plain)
2015-08-29 18:46 EDT, mmg
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-29 18:46 EDT, mmg
no flags Details
File: open_fds (729 bytes, text/plain)
2015-08-29 18:46 EDT, mmg
no flags Details
File: proc_pid_status (954 bytes, text/plain)
2015-08-29 18:47 EDT, mmg
no flags Details
File: var_log_messages (778 bytes, text/plain)
2015-08-29 18:47 EDT, mmg
no flags Details

  None (edit)
Description mmg 2015-08-29 18:46:39 EDT
Version-Release number of selected component:
qt-creator-3.4.2-1.fc22

Additional info:
reporter:       libreport-2.5.1
backtrace_rating: 3
cmdline:        qtcreator
crash_function: __libc_sigaction
executable:     /usr/bin/qtcreator
global_pid:     7930
kernel:         4.0.4-301.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __libc_sigaction at ../sysdeps/unix/sysv/linux/x86_64/sigaction.c:54
 #1 __tls_get_addr at dl-tls.c:830
 #2 ??
 #3 ungrabMessageHandler at global/qlogging.cpp:1514
 #4 qt_message_print at global/qlogging.cpp:1544
 #5 qt_message(enum QtMsgType, const QMessageLogContext &, const char *, typedef __va_list_tag __va_list_tag *) at global/qlogging.cpp:262
 #6 qt_message_fatal at global/qlogging.cpp:1575
 #7 QMessageLogger::fatal at global/qlogging.cpp:777
 #8 QObjectPrivate::QObjectPrivate at kernel/qobject.cpp:199
 #9 QScriptEnginePrivate::QScriptEnginePrivate at /usr/src/debug/qtscript-opensource-src-5.4.1/src/script/api/qscriptengine.cpp:976
Comment 1 mmg 2015-08-29 18:46:44 EDT
Created attachment 1068355 [details]
File: backtrace
Comment 2 mmg 2015-08-29 18:46:45 EDT
Created attachment 1068356 [details]
File: cgroup
Comment 3 mmg 2015-08-29 18:46:47 EDT
Created attachment 1068357 [details]
File: core_backtrace
Comment 4 mmg 2015-08-29 18:46:49 EDT
Created attachment 1068358 [details]
File: dso_list
Comment 5 mmg 2015-08-29 18:46:50 EDT
Created attachment 1068359 [details]
File: environ
Comment 6 mmg 2015-08-29 18:46:52 EDT
Created attachment 1068360 [details]
File: limits
Comment 7 mmg 2015-08-29 18:46:54 EDT
Created attachment 1068361 [details]
File: maps
Comment 8 mmg 2015-08-29 18:46:56 EDT
Created attachment 1068362 [details]
File: mountinfo
Comment 9 mmg 2015-08-29 18:46:57 EDT
Created attachment 1068363 [details]
File: namespaces
Comment 10 mmg 2015-08-29 18:46:59 EDT
Created attachment 1068364 [details]
File: open_fds
Comment 11 mmg 2015-08-29 18:47:00 EDT
Created attachment 1068365 [details]
File: proc_pid_status
Comment 12 mmg 2015-08-29 18:47:02 EDT
Created attachment 1068366 [details]
File: var_log_messages
Comment 13 Sandro Mani 2015-08-30 08:19:48 EDT
The crash is due to

Cannot mix incompatible Qt library (version 0x50401) with this library (version 0x50500)

Please check that your Qt5 packages are up to date and in a consistent state. This is not a qt-creator issue.

Note You need to log in before you can comment on or make changes to this bug.