Bug 1258190 - Unable to limit groups to access only OpenStack cloud providers using Hosts & Clusters filter
Unable to limit groups to access only OpenStack cloud providers using Hosts &...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Dan Clarizio
Dave Johnson
filter:openstack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 00:22 EDT by Vagner Farias
Modified: 2017-06-07 14:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-07 14:43:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vagner Farias 2015-08-30 00:22:19 EDT
Description of problem:
On an environment with a RHEV infrastructure provider and an OpenStack cloud provider, I'd like to limit some user to the latter. However, if I use the group assigned filters feature to limit visibility to the openstack provider (hosts & clusters), no images or instances will be visible to the user, no even if the user should have visibility to this objects according to the smart tags used.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure CloudForms with a RHEV 3.5 infrastructure provider and an RHEL-OSP 6 cloud provider
2. For the "Provisioning Scope" category, add a tag named "dev".
3. Apply "dev" and "all" tags to the openstack provider, at least 1 availability zone, 1 tenant, 1 flavor, 1 security group and 1 image. 
4. Create a group (eg. openstack-group), with role EvmRole-user_self_service
5. Filter this group to Provisioning Scope=dev and Hosts&clusters=<openstack provider name>
6. Create a user (eg. dev) and include him in the group
7. log as the user, navigate to Cloud->Instances->Images

Actual results:
No images are visible to the user, even the ones with Provisioning Scope = dev

Expected results:
Images tagged with Provisioning Scope = dev should be visible to the user.

Additional info:
If the Hosts & Clusters = <openstack provider> filter is removed from the group, the user will have visibility to the tagged images. However, the user will also have visibility to the RHEV provider, if same tags are used.

As a workaround, I'm using different tags for openstack and rhev providers, but this doesn't seem to be optimal, considering there's an option in the UI to automatically filter resources based on providers.
Comment 2 Vagner Farias 2015-08-30 11:36:19 EDT
Version-Release number of selected component (if applicable):
CFME 5.4.1.0
Comment 3 Chris Pelland 2017-06-07 14:43:33 EDT
This BZ has been closed since it was opened on a version of CloudForms that has reached the end of its lifecycle.  If you find that this bug is still relevant, please open a new BZ against the relevant supported version of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.