Bug 1258193 - 0.8 rc1 please?
0.8 rc1 please?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hidapi (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Scott Talbert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 03:17 EDT by Christopher Meng
Modified: 2015-09-01 21:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 21:04:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Meng 2015-08-30 03:17:26 EDT
Hi, 

I haven't seen updates of this for years, can you update it? 

Thanks.
Comment 1 Scott Talbert 2015-08-30 10:49:05 EDT
Are you running into a particular bug?  We're using a git tarball so the version number is a bit misleading.

This is all of the changes since our release (a88c7244d632ed238b829968be9b765605b53c34):

d17db57b9d4354752e0af42f5f33007a42ef2906 header: Update documentation for hid_get_feature_report()
54eb31dc16dcc67d0b689ed947bc53a038608c0e windows: Return the correct length from hid_get_feature_report()
0cbc3a409bcb45cefb3edbf144d64ddd4e0821ce libusb: Adapt to FreeBSD 10
417b2bf0812fa0926704b4cd9cd90af3194a172c libusb: Add Android support
ac6120b58961e5de965a1cd7144068947011fdd9 libusb: Fix null pointer dereference in hid_open()
171a521b91add62c19343100df62b15ecd8f3216 windows: Limit hid_read() return value to buffer length
99d0219a8759e689951f63a499545e3c0e3d8e90 configure: Check for Fox 1.7 as well as Fox 1.6 for the testgui
627f3aa478e8099e3660d6a429f1584eeca0724c windows: Set the OS report buffer size to 64 reports
6a4743ee59d7ca7d29ce63d4c331024493ce990e libusb: Include PTHREAD_CFLAGS when linking libhidapi-libusb
54db8ca208dcfc313cf332e0623f190d832613cf libusb: Add support for compiling on Debian/kFreeBSD
56e8c3939fdb27d145ec9516d4a61a549674fbea hidtest: Remove "All Rights Reserved" from hidtest.cpp
3a66d4e513ed1b1ce82b7e6fcfa30ff05598b696 linux: Better kernel version detection
1a42177fa5f3beddb8805cb676d50acbc5e8ed01 header: Clarify comment on hid_read() and hid_read_timeout()
40cf516139b5b61e30d9403a48db23d8f915f52c HIDAPI 0.8.0-rc1
4ecb5a6903b77d16f63cceb4fc4741b7c58c3868 autotools: Add mac_support.h to Makefile.am
837ba310501c374e7137070864c8acca3641ebe0 testgui: Remove pre-built testgui executable
996dafd2a8d92df7d870d80556932c4dd86acca0 libusb: Fix 'dev' memory leak on hid_init() failure.
2e27f98b3ef19826e8658408b8f172e306e5af95 all: Fix license name

As you can see, very few of them are applicable to Linux so that's the main reason I haven't bothered to update the package.

Note You need to log in before you can comment on or make changes to this bug.