Bug 1258214 - [abrt] ibus: bus_dbus_impl_connection_filter_cb(): ibus-daemon killed by SIGABRT
[abrt] ibus: bus_dbus_impl_connection_filter_cb(): ibus-daemon killed by SIGABRT
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
21
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:49fa7f8905783ab94fc86f0af07...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 06:33 EDT by Frank Büttner
Modified: 2015-09-29 02:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-29 02:22:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (61.37 KB, text/plain)
2015-08-30 06:33 EDT, Frank Büttner
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-30 06:33 EDT, Frank Büttner
no flags Details
File: core_backtrace (41.88 KB, text/plain)
2015-08-30 06:33 EDT, Frank Büttner
no flags Details
File: dso_list (3.24 KB, text/plain)
2015-08-30 06:33 EDT, Frank Büttner
no flags Details
File: environ (1.87 KB, text/plain)
2015-08-30 06:33 EDT, Frank Büttner
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-30 06:33 EDT, Frank Büttner
no flags Details
File: maps (15.61 KB, text/plain)
2015-08-30 06:33 EDT, Frank Büttner
no flags Details
File: open_fds (1.51 KB, text/plain)
2015-08-30 06:33 EDT, Frank Büttner
no flags Details
File: proc_pid_status (1.01 KB, text/plain)
2015-08-30 06:33 EDT, Frank Büttner
no flags Details

  None (edit)
Description Frank Büttner 2015-08-30 06:33:31 EDT
Version-Release number of selected component:
ibus-1.5.10-5.fc21

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        ibus-daemon --xim --panel disable
crash_function: bus_dbus_impl_connection_filter_cb
executable:     /usr/bin/ibus-daemon
kernel:         4.1.5-100.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 bus_dbus_impl_connection_filter_cb at dbusimpl.c:1473
 #5 on_worker_message_about_to_be_sent at gdbusconnection.c:2429
 #6 continue_writing at gdbusprivate.c:497
 #8 write_message_cb at gdbusprivate.c:1352
 #9 g_simple_async_result_complete at gsimpleasyncresult.c:763
 #10 write_message_continue_writing at gdbusprivate.c:1066
 #11 write_message_async at gdbusprivate.c:1132
 #12 continue_writing at gdbusprivate.c:1532
 #13 write_message_cb at gdbusprivate.c:1352
 #14 g_simple_async_result_complete at gsimpleasyncresult.c:763
Comment 1 Frank Büttner 2015-08-30 06:33:35 EDT
Created attachment 1068403 [details]
File: backtrace
Comment 2 Frank Büttner 2015-08-30 06:33:36 EDT
Created attachment 1068404 [details]
File: cgroup
Comment 3 Frank Büttner 2015-08-30 06:33:38 EDT
Created attachment 1068405 [details]
File: core_backtrace
Comment 4 Frank Büttner 2015-08-30 06:33:39 EDT
Created attachment 1068406 [details]
File: dso_list
Comment 5 Frank Büttner 2015-08-30 06:33:40 EDT
Created attachment 1068407 [details]
File: environ
Comment 6 Frank Büttner 2015-08-30 06:33:41 EDT
Created attachment 1068408 [details]
File: limits
Comment 7 Frank Büttner 2015-08-30 06:33:43 EDT
Created attachment 1068409 [details]
File: maps
Comment 8 Frank Büttner 2015-08-30 06:33:44 EDT
Created attachment 1068410 [details]
File: open_fds
Comment 9 Frank Büttner 2015-08-30 06:33:45 EDT
Created attachment 1068411 [details]
File: proc_pid_status
Comment 10 fujiwara 2015-08-30 22:57:31 EDT
I cannot reproduce your backtrace.
Are you still able to reproduce your backtrace?

(In reply to Frank Büttner from comment #1)
> Created attachment 1068403 [details]
> File: backtrace

#0  0x00000030492348d7 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:55
#1  0x000000304923653a in __GI_abort () at abort.c:89
#2  0x0000003048e6f5d5 in g_assertion_message (domain=domain@entry=0x419226 "IBUS", file=file@entry=0x4196e6 "dbusimpl.c", line=line@entry=1473, func=func@entry=0x419d20 <__func__.25050> "bus_dbus_impl_connection_filter_cb", message=message@entry=0x7f565c021bb0 "assertion failed: (connection != NULL)") at gtestutils.c:2292
#3  0x0000003048e6f66a in g_assertion_message_expr (domain=domain@entry=0x419226 "IBUS", file=file@entry=0x4196e6 "dbusimpl.c", line=line@entry=1473, func=func@entry=0x419d20 <__func__.25050> "bus_dbus_impl_connection_filter_cb", expr=expr@entry=0x4196f1 "connection != NULL") at gtestutils.c:2307
#4  0x000000000040a14f in bus_dbus_impl_connection_filter_cb (dbus_connection=<optimized out>, message=0x7f565c013630 [GDBusMessage], incoming=0, user_data=0xa16830) at dbusimpl.c:1473
Comment 11 Frank Büttner 2015-08-31 02:26:57 EDT
I can try it, when you say me how.
Comment 12 fujiwara 2015-08-31 03:20:12 EDT
(In reply to Frank Büttner from comment #11)
> I can try it, when you say me how.

How often can you reproduce your backtrace?
How do you reproduce your problem?
Comment 13 Frank Büttner 2015-08-31 03:28:30 EDT
This was happened on very high system load and open the qtcreator twice. 
I don't know if that was the reason for it.
Comment 14 fujiwara 2015-09-01 02:44:49 EDT
(In reply to Frank Büttner from comment #13)
> This was happened on very high system load and open the qtcreator twice. 
> I don't know if that was the reason for it.

I cannot reproduce your backtrace with qtcreator.
I'm asking the reproducing steps with detail because:
1. If I can reproduce your problem, I can fix your problem in my desktop.
2. If I cannot reproduce your problem but you always can reproduce, I can ask you to send the test binary if your problem is fixed.

Now I created the test binary below:
https://fujiwara.fedorapeople.org/ibus/20150901/10908599/

Would you replace the ibus rpms and check if your problem is fixed?

If your problem is not fixed with the test binary, please attach /var/tmp/ibus-daemon.log in this bug report.
Comment 15 Frank Büttner 2015-09-01 03:12:53 EDT
I will test it on weekend, when the same load scenario will be occurs.
Comment 16 Frank Büttner 2015-09-06 03:59:40 EDT
I  can't install your packages:
udo LANG=C yum update /tmp/xx/*.rpm
Loaded plugins: changelog, fastestmirror, langpacks
Examining /tmp/xx/ibus-1.5.10-5.1.fc21.x86_64.rpm: ibus-1.5.10-5.1.fc21.x86_64
Marking /tmp/xx/ibus-1.5.10-5.1.fc21.x86_64.rpm as an update to ibus-1.5.10-5.fc21.x86_64
Examining /tmp/xx/ibus-devel-1.5.10-5.1.fc21.x86_64.rpm: ibus-devel-1.5.10-5.1.fc21.x86_64
Package ibus-devel not installed, cannot update it. Run yum install to install it instead.
Examining /tmp/xx/ibus-gtk2-1.5.10-5.1.fc21.x86_64.rpm: ibus-gtk2-1.5.10-5.1.fc21.x86_64
Marking /tmp/xx/ibus-gtk2-1.5.10-5.1.fc21.x86_64.rpm as an update to ibus-gtk2-1.5.10-5.fc21.x86_64
Examining /tmp/xx/ibus-gtk3-1.5.10-5.1.fc21.x86_64.rpm: ibus-gtk3-1.5.10-5.1.fc21.x86_64
Marking /tmp/xx/ibus-gtk3-1.5.10-5.1.fc21.x86_64.rpm as an update to ibus-gtk3-1.5.10-5.fc21.x86_64
Examining /tmp/xx/ibus-libs-1.5.10-5.1.fc21.x86_64.rpm: ibus-libs-1.5.10-5.1.fc21.x86_64
Marking /tmp/xx/ibus-libs-1.5.10-5.1.fc21.x86_64.rpm as an update to ibus-libs-1.5.10-5.fc21.x86_64
Examining /tmp/xx/ibus-setup-1.5.10-5.1.fc21.noarch.rpm: ibus-setup-1.5.10-5.1.fc21.noarch
Marking /tmp/xx/ibus-setup-1.5.10-5.1.fc21.noarch.rpm as an update to ibus-setup-1.5.10-5.fc21.noarch
Resolving Dependencies
--> Running transaction check
---> Package ibus.x86_64 0:1.5.10-5.fc21 will be updated
--> Processing Dependency: ibus(x86-64) = 1.5.10-5.fc21 for package: ibus-wayland-1.5.10-5.fc21.x86_64
Loading mirror speeds from cached hostfile
 * fedora: ftp.uni-bayreuth.de
 * rpmfusion-free: ftp-stud.hs-esslingen.de
 * rpmfusion-free-updates: ftp-stud.hs-esslingen.de
 * rpmfusion-nonfree: ftp-stud.hs-esslingen.de
 * rpmfusion-nonfree-updates: ftp-stud.hs-esslingen.de
 * updates: ftp.uni-bayreuth.de
---> Package ibus.x86_64 0:1.5.10-5.1.fc21 will be an update
--> Processing Dependency: ibus-wayland(x86-64) = 1.5.10-5.1.fc21 for package: ibus-1.5.10-5.1.fc21.x86_64
---> Package ibus-gtk2.x86_64 0:1.5.10-5.fc21 will be updated
---> Package ibus-gtk2.x86_64 0:1.5.10-5.1.fc21 will be an update
---> Package ibus-gtk3.x86_64 0:1.5.10-5.fc21 will be updated
---> Package ibus-gtk3.x86_64 0:1.5.10-5.1.fc21 will be an update
---> Package ibus-libs.x86_64 0:1.5.10-5.fc21 will be updated
--> Processing Dependency: ibus-libs(x86-64) = 1.5.10-5.fc21 for package: ibus-wayland-1.5.10-5.fc21.x86_64
---> Package ibus-libs.x86_64 0:1.5.10-5.1.fc21 will be an update
---> Package ibus-setup.noarch 0:1.5.10-5.fc21 will be updated
---> Package ibus-setup.noarch 0:1.5.10-5.1.fc21 will be an update
--> Finished Dependency Resolution
Error: Package: ibus-wayland-1.5.10-5.fc21.x86_64 (@updates)
           Requires: ibus-libs(x86-64) = 1.5.10-5.fc21
           Removing: ibus-libs-1.5.10-5.fc21.x86_64 (@updates)
               ibus-libs(x86-64) = 1.5.10-5.fc21
           Updated By: ibus-libs-1.5.10-5.1.fc21.x86_64 (/ibus-libs-1.5.10-5.1.fc21.x86_64)
               ibus-libs(x86-64) = 1.5.10-5.1.fc21
           Available: ibus-libs-1.5.9-5.fc21.x86_64 (fedora)
               ibus-libs(x86-64) = 1.5.9-5.fc21
Error: Package: ibus-wayland-1.5.10-5.fc21.x86_64 (@updates)
           Requires: ibus(x86-64) = 1.5.10-5.fc21
           Removing: ibus-1.5.10-5.fc21.x86_64 (@updates)
               ibus(x86-64) = 1.5.10-5.fc21
           Updated By: ibus-1.5.10-5.1.fc21.x86_64 (/ibus-1.5.10-5.1.fc21.x86_64)
               ibus(x86-64) = 1.5.10-5.1.fc21
           Available: ibus-1.5.9-5.fc21.x86_64 (fedora)
               ibus(x86-64) = 1.5.9-5.fc21
Error: Package: ibus-1.5.10-5.1.fc21.x86_64 (/ibus-1.5.10-5.1.fc21.x86_64)
           Requires: ibus-wayland(x86-64) = 1.5.10-5.1.fc21
           Installed: ibus-wayland-1.5.10-5.fc21.x86_64 (@updates)
               ibus-wayland(x86-64) = 1.5.10-5.fc21
           Available: ibus-wayland-1.5.9-5.fc21.x86_64 (fedora)
               ibus-wayland(x86-64) = 1.5.9-5.fc21
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
libcapi20-3-20131212-13.1.x86_64 has installed conflicts libcapi20: libcapi20-3-20131212-13.1.x86_64
libcapi20-3-20131212-13.1.x86_64 has installed conflicts libcapi20-2: libcapi20-3-20131212-13.1.x86_64
Comment 17 fujiwara 2015-09-06 22:31:29 EDT
(In reply to Frank Büttner from comment #16)
> --> Processing Dependency: ibus-wayland(x86-64) = 1.5.10-5.1.fc21 for
> package: ibus-1.5.10-5.1.fc21.x86_64

Sorry, I didn't think you have ibus-wayland.
Could you also dowload it below and try the test again?
https://kojipkgs.fedoraproject.org//work/tasks/8601/10908601/ibus-wayland-1.5.10-5.1.fc21.x86_64.rpm
Comment 18 Frank Büttner 2015-09-07 01:41:12 EDT
Now the packages will install.
I will report you next sunday what is happened now, because the heavy load will only happened once a week.
Comment 19 Frank Büttner 2015-09-13 13:54:12 EDT
So good new's no crash on heavy system load.
Comment 20 fujiwara 2015-09-13 22:09:45 EDT
Actually I don't think the updated packages fix your problem.
Can you revert the ibus packages to 1.5.10-5 and check if you still reproduce your problem again?
Comment 21 Frank Büttner 2015-09-14 10:37:54 EDT
sudo yum downgrade ibus ibus-gtk3 ibus-wayland ibus-libs ibus-gtk2 ibus-setup
And wait what now happens at the next weekend.
Comment 22 Frank Büttner 2015-09-20 13:09:06 EDT
So I tested again with the same scenario.
But today no crash.
Comment 23 fujiwara 2015-09-29 02:22:56 EDT
It means we cannot verify if the bug is fixed.
Please comment here if you reproduce the bug again.

Note You need to log in before you can comment on or make changes to this bug.