Bug 1258216 - koji chain-build : Could not execute chainbuild: (-1, 'Unexpected EOF')
koji chain-build : Could not execute chainbuild: (-1, 'Unexpected EOF')
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-30 07:25 EDT by Rex Dieter
Modified: 2015-09-28 15:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: koji-1.10.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 15:30:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2015-08-30 07:25:45 EDT
Since upgrading to koji-1.10.0-1.fc22, I've been unable to use 'koji chain-build' successfully, it fails with error:
Could not execute chainbuild: (-1, 'Unexpected EOF')

Dowgrading to 
koji-1.9.0-11.fc22.20150423git52a0188
and it works again.
Comment 1 Michael Simacek 2015-09-07 04:01:02 EDT
I tried to debug this a bit, and commenting out the call to getFullInheritance in /usr/bin/koji makes it work again. The call to getFullInheritance itself succeeds, but then makes the following chainBuild call fail.
Note this affects building, not just watching tasks.
Comment 2 Mamoru TASAKA 2015-09-22 06:18:51 EDT
Same for F-23.
Comment 3 Rex Dieter 2015-09-28 15:30:35 EDT
Seems to be fixed in koji-1.10.0-2 in testing for me.

Note You need to log in before you can comment on or make changes to this bug.