Bug 125823 - missing dependencies flex and libtool
Summary: missing dependencies flex and libtool
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: a2ps
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-11 21:04 UTC by Simon J Mudd
Modified: 2007-11-30 22:07 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-06-24 17:41:42 UTC


Attachments (Terms of Use)

Description Simon J Mudd 2004-06-11 21:04:44 UTC
Description of problem:

Missing dependencies when rebuilding from source rpm.

Version-Release number of selected component (if applicable):

a2ps-4.13b-28.src.rpm

Steps to Reproduce:

[buildsys@ams03 buildsys]$ rpmbuild --rebuild
~/repo/os/SRPMS/a2ps-4.13b-28.src.rpm
Installing /home/buildsys/repo/os/SRPMS/a2ps-4.13b-28.src.rpm
Executing(%prep): /bin/sh -e /home/buildsys/rpm/tmp/rpm-tmp.99905
+ umask 022
+ cd /home/buildsys/rpm/BUILD
+ cd /home/buildsys/rpm/BUILD
+ rm -rf a2ps-4.13
+ /bin/gzip -dc /home/buildsys/rpm/SOURCES/a2ps-4.13b.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd a2ps-4.13
+ /bin/gzip -dc /home/buildsys/rpm/SOURCES/i18n-fonts-0.1.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
++ /usr/bin/id -u
+ '[' 505 = 0 ']'
++ /usr/bin/id -u
+ '[' 505 = 0 ']'
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ echo 'Patch #0 (a2ps-4.13-conf.patch):'
Patch #0 (a2ps-4.13-conf.patch):
+ patch -p1 -s
+ echo 'Patch #1 (a2ps-4.13-etc.patch):'
Patch #1 (a2ps-4.13-etc.patch):
+ patch -p1 -s
+ echo 'Patch #2 (a2ps-4.13-flex.patch):'
Patch #2 (a2ps-4.13-flex.patch):
+ patch -p1 -s
+ echo 'Patch #3 (a2ps-4.13-security.patch):'
Patch #3 (a2ps-4.13-security.patch):
+ patch -p1 -b --suffix .security -s
+ echo 'Patch #4 (a2ps-4.13-glibcpaper.patch):'
Patch #4 (a2ps-4.13-glibcpaper.patch):
+ patch -p1 -b --suffix .glibcpaper -s
+ echo 'Patch #5 (a2ps-4.13-varargs.patch):'
Patch #5 (a2ps-4.13-varargs.patch):
+ patch -p1 -s
+ echo 'Patch #10 (a2ps-4.13-eucjp.patch.bz2):'
Patch #10 (a2ps-4.13-eucjp.patch.bz2):
+ /usr/bin/bzip2 -d
+ patch -p1 -b --suffix .euc -s
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ echo 'Patch #11 (a2ps-4.13-autoenc.patch):'
Patch #11 (a2ps-4.13-autoenc.patch):
+ patch -p1 -b --suffix .ae -s
+ echo 'Patch #12 (a2ps-4.13b-attr.patch):'
Patch #12 (a2ps-4.13b-attr.patch):
+ patch -p1 -b --suffix .attr -s
+ echo 'Patch #13 (a2ps-4.13b-numeric.patch):'
Patch #13 (a2ps-4.13b-numeric.patch):
+ patch -p1 -b --suffix .numeric -s
+ echo 'Patch #14 (a2ps-4.13b-encoding.patch):'
Patch #14 (a2ps-4.13b-encoding.patch):
+ patch -p1 -b --suffix .encoding -s
+ echo 'Patch #15 (a2ps-4.13b-tilde.patch):'
Patch #15 (a2ps-4.13b-tilde.patch):
+ patch -p1 -b --suffix .tilde -s
+ echo 'Patch #16 (a2ps-4.13b-rm.patch):'
Patch #16 (a2ps-4.13b-rm.patch):
+ patch -p1 -b --suffix .rm -s
+ echo 'Patch #17 (a2ps-4.13-euckr.patch):'
Patch #17 (a2ps-4.13-euckr.patch):
+ patch -p1 -b --suffix .euckr -s
+ libtoolize --copy --force
/home/buildsys/rpm/tmp/rpm-tmp.99905: line 82: libtoolize: command not
found
error: Bad exit status from /home/buildsys/rpm/tmp/rpm-tmp.99905 (%prep)


RPM build errors:
    Bad exit status from /home/buildsys/rpm/tmp/rpm-tmp.99905 (%prep)
[buildsys@ams03 buildsys]$

Additional info:

installing libtool and flex allows the build to work.

Comment 1 Tim Waugh 2004-06-24 17:41:42 UTC
flex is already required.  I've added libtool.


Note You need to log in before you can comment on or make changes to this bug.