Bug 125824 - kernel 2.6.6-1.427 triggered problem with pppd
kernel 2.6.6-1.427 triggered problem with pppd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-11 17:06 EDT by Gavin C. Flower
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 06:28:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
extract of messages log for new kernel (49.95 KB, text/plain)
2004-06-11 17:36 EDT, Gavin C. Flower
no flags Details
Shows processer usage & messages on an xterm (116.09 KB, image/png)
2004-06-12 14:17 EDT, Gavin C. Flower
no flags Details
ip-route-fix-refcount.patch (3.35 KB, patch)
2004-06-13 06:23 EDT, Ingo Molnar
no flags Details | Diff

  None (edit)
Description Gavin C. Flower 2004-06-11 17:06:25 EDT
Description of problem:
Deactivated the network control panel, then I noticed that pppd had
suddenly started using almost all the processor, and every terminal
started spouting messages... That was over 8 minutes ago!

Version-Release number of selected component (if applicable):
Linux jupiter 2.6.6-1.427 #1 Thu Jun 10 09:33:46 EDT 2004 i686 i686
i386 GNU/Linux


How reproducible:
It happened twive in less than an hour.  However, I successfully
deactivated about twice.  So it is very roughly 50% (2 out of 4
attempts triggered the problem),

Steps to Reproduce:
1. Upgrade kernel.
2. Activate Network Device Control
3. use the net
4. eactivate
5. repeat steps 1 to 4 until it happenns
  
Actual results:
Evry xterm started spouting messages... 

Message from syslogd@jupiter at Fri Jun 11 19:50:44 2004 ...
jupiter kernel: unregister_netdevice: waiting for ppp0 to become free.
Usage count = 1
 
Message from syslogd@jupiter at Fri Jun 11 19:51:24 2004 ...
jupiter last message repeated 4 times
 
Message from syslogd@jupiter at Fri Jun 11 20:13:32 2004 ...
jupiter kernel: unregister_netdevice: waiting for ppp0 to become free.
Usage count = 1

[... still going after 10 minutes, until I forced shutdown]

Expected results:
After a short interval, connection is terminated, the modem lights go
off, and at no stage should the procesor usage hit 90+% for more than
a faction of a second.

Additional info:
I'm using an external dialup modem.

This was the first session with the new kernel.  Nothing like it
happened with the old kernel,

Acording to "yum check-update", I'm uptodate with all relevent components.
Comment 1 Gavin C. Flower 2004-06-11 17:36:30 EDT
Created attachment 101072 [details]
extract of messages log for new kernel

Hopefully, this will shed some light on the problem.. The new 2.6.6 kernel did
seem to be a bit faster, but now I've reverted back. :-(
Comment 2 Gavin C. Flower 2004-06-11 20:16:05 EDT
Well I've gone back to using the new kernel.

I'm still getting messages displayed on my xterms, but they only
appear a small number of times, but no sign of the excessive and
prolonged processsor utilisation fortunately.

typical message:
unregister_netdevice: waiting for ppp0 to become free. Usage count = 1
Comment 3 Gavin C. Flower 2004-06-12 14:17:17 EDT
Created attachment 101086 [details]
Shows processer usage & messages on an xterm
Comment 4 Gavin C. Flower 2004-06-12 14:18:42 EDT
Well, I'm still using the 2,6.6 kernel.

There seemes to be 4 "modes":

MODE 1:
I've noted that sometimes I can deactivate and there appear to be
absolutely no problems, this seenms to be the most common mode
(excepting the first 4 times... in the first seesion with 2.6.6)

Mode 2:
Then sometimes I get system messages on all the xterms, but processor
usage seems "normal"

Mode 3:
Like mode 2, but a burst of intense processor usage for anything from
several seconds to several minutes.

Mode 4:
This probably same as mode 3, but when the processor usage is close to
100% and I keep getting meesages on xterms for over ten minutes, I'm
inclined to reboot.

The attached file "pppd20040612x.png" shows a mode 3 type.  It shows
top displaying 98.9% processor usage for pppd, and another xterm with
system messages.
Comment 5 Ingo Molnar 2004-06-13 06:23:21 EDT
Created attachment 101091 [details]
ip-route-fix-refcount.patch

The attached patch is from lkml, it seems to fix a related bug.
Comment 6 Ingo Molnar 2004-06-14 05:18:29 EDT
the 433 kernel from Arjan which includes another patch from DaveM
fixes the problem for me.
Comment 7 tom georgoulias 2004-06-14 08:47:01 EDT
I used the attached patch with the kernel 2.6.6-1.427 SRPM and the bug
is gone, at least for now.  I haven't done too much testing to
quantify it, but it was pretty bad before so anything is an
improvement at this point.
Comment 8 Gavin C. Flower 2004-06-15 05:24:39 EDT
The problem appears fixed after I installed kernel 2.6.6-1.435.

Since then I have activated & deactivated 20 times, with no sign of
the "kernel: unregister_netdevice: waiting for ppp0 to become free.
Usage count = 1" message appearing in the log.  With the kernel
2.6.6-1.427, I had 73 pppd sessions, and the system logged 108 of the
above error messages.

I am happy for this bug to be closed as fixed, but I'm not sure who
should do so.

Note You need to log in before you can comment on or make changes to this bug.